Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Jul 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    IE6 alignment issue...

    I'm new to CSS and don't understand why the page doesn't render in IE6, but does so in IE7 and Firefox:
    http://home.cogeco.ca/~gary.tai/rotaryhamiltonsunset/

    This is a mock up for testing.

    If anyone can point me in the right direction, I'd greatly appreciate the help.

    Thanks.

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    First get rid of clear:both; on your .left div. Then get rid of the tables. They aren't needed and they are causing your problem because IE is reading the width:100%; incorrectly.

    Finally read the link in my sig titled "Why Tables for Layout is Stupid?".
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New to the CF scene
    Join Date
    Jul 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Aerospace_Eng_ for the help. Getting rid of the width fixed the alignment issue. I'll re-do the pages without the tables.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •