Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 12 of 12
  1. #1
    New Coder
    Join Date
    Jun 2007
    Posts
    21
    Thanks
    1
    Thanked 0 Times in 0 Posts

    IE breaks my pretty menu

    http://www.antheliadesigns.com/css/justmenu.html

    This menu works perfectly in FF, IE7, etc, but breaks in IE6. I am using Dean Edwards' ie7 javascript folder (http://dean.edwards.name/IE7/) which gives a little help on the first level of hover, but doesn't quite get me there.

    It is a 3 level menu. The first level is meant to display the black and white buttons, which turn red upon mouse-over. This works.

    The second level is meant to be silver with black text, and to turn blue with white text upon mouse-over. This isn't working in my example version here, but that doesn't bother me. The *REAL* trouble is that the background image for the top level is inheriting down to the second level.

    My second big problem is that the third level is not displaying at all. If you go to the "Act" button, its fourth option ought to have a third level under it.


    Can anyone help? I can't even begin to tell you all the things I've tried. Nothing seems to be working.

    Thank you!!!

  • #2
    Regular Coder
    Join Date
    Feb 2007
    Location
    Canada
    Posts
    924
    Thanks
    10
    Thanked 56 Times in 55 Posts

  • #3
    New Coder
    Join Date
    Jun 2007
    Posts
    21
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I believe that is where the menu code originally came from, only I've messed with it. Especially adding an image to the top level is something Stu usually doesn't do.

    Is there anything specific on that site you were suggesting I review?

  • #4
    Regular Coder
    Join Date
    Feb 2007
    Location
    Canada
    Posts
    924
    Thanks
    10
    Thanked 56 Times in 55 Posts
    have you looked at the flyout menus on that site?

  • #5
    New to the CF scene
    Join Date
    Jul 2007
    Location
    USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have similar issue

    Hello,

    I too am having trouble with my menu in IE.

    This menu works 100% perfect in FF but not IE

    The problem is that the background image for the top level is inheriting down to the second level in IE.... thats the only thing I can't figure out.

    Here is the link to my menu:
    http://www.blueflamesearch.com/menu.html

    Can someone please look at my source and tell me what I can do to get it working right in IE.

    Thank you,
    Ryan

  • #6
    Regular Coder BWiz's Avatar
    Join Date
    Mar 2006
    Location
    Sol System
    Posts
    471
    Thanks
    7
    Thanked 21 Times in 21 Posts
    @epro

    Try adding a background-image: none; to the .drop
    BWiz :: Happy Coding!
    2006
    2007 2008 2009
    2010 2011
    Irrational numbers make no sense.

  • #7
    New to the CF scene
    Join Date
    Jul 2007
    Location
    USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the advice, but I tried adding the "background-image: none;" to the .drop class and still have the same issue.

  • #8
    Regular Coder Jutlander's Avatar
    Join Date
    Jun 2007
    Location
    In my own sick little world :P
    Posts
    425
    Thanks
    1
    Thanked 12 Times in 12 Posts
    You have 4 errors in your CSS and they're all related to your backgrounds in your menu. I suggest you fix them as this may solve the problem:

    http://jigsaw.w3.org/css-validator/v.../justmenu.html
    .
    .

  • #9
    New to the CF scene
    Join Date
    Jul 2007
    Location
    USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have errors in my css as well:

    http://jigsaw.w3.org/css-validator/v....com/menu.html

    I doubt it, but could that be the cause of my IE issue?

  • #10
    Regular Coder Jutlander's Avatar
    Join Date
    Jun 2007
    Location
    In my own sick little world :P
    Posts
    425
    Thanks
    1
    Thanked 12 Times in 12 Posts
    Quote Originally Posted by epro View Post
    I have errors in my css as well:
    It was your CSS I validated... 4 errors all about the background property in your menu. I think there's a good chance that this is what's causing it.
    .
    .

  • #11
    New to the CF scene
    Join Date
    Jul 2007
    Location
    USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    no, you validated the person who started this thread, not mine...

    look at the previous posts...

    here is what you validated:
    www.antheliadesigns.com/css/justmenu.html

    here is mine:
    www.blueflamesearch.com/menu.html

    I only have 3 errors in mine, relating to the .drop class of my css.
    Last edited by epro; 07-29-2007 at 11:18 PM. Reason: misspelled

  • #12
    Regular Coder Jutlander's Avatar
    Join Date
    Jun 2007
    Location
    In my own sick little world :P
    Posts
    425
    Thanks
    1
    Thanked 12 Times in 12 Posts
    Perhaps it would be a good idea to start your own thread then?
    .
    .


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •