Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    Senior Coder twodayslate's Avatar
    Join Date
    Mar 2007
    Location
    VA
    Posts
    1,042
    Thanks
    67
    Thanked 39 Times in 39 Posts

    Background disapears on sublink hover

    http://twodayslate.com/

    I am trying to make the navigation look better after reading my reviews. I have what I want for the current link but the background disappears on the hover of the link's sub links.

    The current link has a tab above it. Tab breaks up when the sub links are hovered.

    Just thought I would post before I go to bed and see if I get any replies.


    Thanks!
    twitter | Quality Hosting - $5.95/mo*
    Feel free to PM me!

  • #2
    Senior Coder koyama's Avatar
    Join Date
    Dec 2006
    Location
    Copenhagen, Denmark
    Posts
    1,246
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Quote Originally Posted by twodayslate View Post
    I have what I want for the current link but the background disappears on the hover of the link's sub links.
    Hmm... I don't see the issue. I tried in Firefox 2. There seems to be no change in background color when you hover any of the links.

  • #3
    Senior Coder twodayslate's Avatar
    Join Date
    Mar 2007
    Location
    VA
    Posts
    1,042
    Thanks
    67
    Thanked 39 Times in 39 Posts
    Here is the problem: http://img403.imageshack.us/img403/1228/deletesc9.gif

    Thanks for the reply!
    twitter | Quality Hosting - $5.95/mo*
    Feel free to PM me!

  • #4
    Senior Coder koyama's Avatar
    Join Date
    Dec 2006
    Location
    Copenhagen, Denmark
    Posts
    1,246
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Quote Originally Posted by twodayslate View Post
    Ok, I see the problem. But you need to tell us how should it look? Should the tab change appearance when you hover over some of the items?

  • #5
    Senior Coder twodayslate's Avatar
    Join Date
    Mar 2007
    Location
    VA
    Posts
    1,042
    Thanks
    67
    Thanked 39 Times in 39 Posts
    The tab should not change.
    twitter | Quality Hosting - $5.95/mo*
    Feel free to PM me!

  • #6
    Senior Coder koyama's Avatar
    Join Date
    Dec 2006
    Location
    Copenhagen, Denmark
    Posts
    1,246
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Quote Originally Posted by twodayslate View Post
    The tab should not change.
    In that case all this seems to be redundant. It is even causing the undesired rendering:
    Code:
    #navigationdiv .current li:hover {
    	background: url(http://images.twodayslate.com/design/currentlinkcornerrightpiece.png) no-repeat top right;
    }
    #navigationdiv .current a:hover{
    	background: url(http://images.twodayslate.com/design/currentlinkcornerleftpiece.png) no-repeat top left;
    }
    #navigationdiv .select a:hover, 
    #navigationdiv li:hover a {
    	background-position:0% -150px;
    }
    #navigationdiv .select a:hover b, 
    #navigationdiv .select li:hover a b {
    	background-position:100% -150px;  
    }

  • #7
    Senior Coder twodayslate's Avatar
    Join Date
    Mar 2007
    Location
    VA
    Posts
    1,042
    Thanks
    67
    Thanked 39 Times in 39 Posts
    I guess this is what I get from copy and pasting code from CSSplay! >: (

    I will fix/edit the CSS more tomorrow (it is late right now) and see if I get the result I want.

    Keep you posted and thanks for the reply. : )


    edit:// Thank you! Getting rid of background position fixed it, now the width of the tab is not across the text. Moving current to forums so you can see the error. Thanks again for your help!
    Last edited by twodayslate; 07-15-2007 at 04:28 AM.
    twitter | Quality Hosting - $5.95/mo*
    Feel free to PM me!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •