Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 12 of 12
  1. #1
    New to the CF scene
    Join Date
    Jun 2002
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question css syntax again

    hey guys i tried your suggestions, but it still doesn't work. When I enter the site I see the default blue color with the underline on the links. Its only when I VISIT the specific link, it changes. Take a look @:

    http://www.tamiu.edu/cost/son/dnurs.htm

    for the css code:
    http://www.tamiu.edu/cost/son/style/style.css

    thanx guys!
    Last edited by jsanchezgoku; 07-01-2002 at 10:36 PM.

  • #2
    Regular Coder
    Join Date
    May 2002
    Location
    Maine, USA
    Posts
    573
    Thanks
    0
    Thanked 0 Times in 0 Posts
    jsanchezgoku, you should have kept this with your original thread by simply adding what you used to create a new thread as a reply to your original thread. That way everyone can follow along with what's been suggested already. It also help to eliminate the confusion of having two threads open for one question. This is covered in the 'Rules' (double posting). Just letting you know .

    Edit: The original thread: http://www.codingforums.com/showthre...&threadid=1151
    Last edited by boxer_1; 07-01-2002 at 10:31 PM.
    boxer_1
    CodingForums Moderator
    "How did a fool and his money get together in the first place?"

  • #3
    New to the CF scene
    Join Date
    Jun 2002
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    my bad

  • #4
    Regular Coder
    Join Date
    May 2002
    Location
    Maine, USA
    Posts
    573
    Thanks
    0
    Thanked 0 Times in 0 Posts
    You kind of did things in reverse order, you deleted the original with 2 replies and some code. I guess we'll have to continue the discussion in this thread now (which will hopefully not be deleted . Anyway, I believe your problem lies with the missing semi-colon here:

    <style type="text/css">
    a:link {color: #3B28B4; text-decoration: none;}
    a:visited {color: #3B28B4; text-decoration: none;}
    a:hover {color: #FFFFFF; text-decoration: underline; background:#3B28B4}
    a:active {color: #3B28B4; text-decoration: none;}
    body {scrollbar-base-color: #3B28B4;
    scrollbar-face-color: #3B28B4;
    scrollbar-track-color: #FFFFFF;
    scrollbar-arrow-color: #FFFFFF;
    scrollbar-highlight-color: #FFFFFF;
    scrollbar-3dlight-color: #3B28B4;
    scrollbar-shadow-color: #FFFFFF;
    scrollbar-darkshadow-color: #3B28B4;}
    .menu {border: 3px solid #3B28B4; text-align:left; font-size: 14}
    .box {border: 1px solid #3B28B4; border-width: thin; font-size: 12}
    </style>

    Try adding the semi-colon after '#3B28B4' and see if that helps .
    boxer_1
    CodingForums Moderator
    "How did a fool and his money get together in the first place?"

  • #5
    New to the CF scene
    Join Date
    Jun 2002
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    still doesn't work, but thanx for the missing ';' i didn't see that one...sorry about the thread

  • #6
    Regular Coder Feyd's Avatar
    Join Date
    May 2002
    Location
    Los Angeles, CA Maxim: Subvert Society
    Posts
    403
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Wait a minute, you are using an external style sheet, but are you still writing <style type blah blah and the closing style tag in the .css file itself?
    Moderator, Perl/CGI Forum
    shadowstorm.net - subvert society

  • #7
    New to the CF scene
    Join Date
    Jun 2002
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    ya...is that bad?

  • #8
    Regular Coder
    Join Date
    May 2002
    Location
    Maine, USA
    Posts
    573
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by Feyd
    Wait a minute, you are using an external style sheet, but are you still writing <style type blah blah and the closing style tag in the .css file itself?
    Good catch Feyd, that would cause the problem...I missed the most obvious thing . Kinda reminds me of something that happened with a certain someone and the [img] tag when we were testing...lol (j/k).

    Edit: Yes, try removing the <style>...</style> tags from your external style sheet and see if that helps .
    Last edited by boxer_1; 07-01-2002 at 11:05 PM.
    boxer_1
    CodingForums Moderator
    "How did a fool and his money get together in the first place?"

  • #9
    Regular Coder
    Join Date
    Jun 2002
    Location
    Dallas, Texas
    Posts
    188
    Thanks
    0
    Thanked 0 Times in 0 Posts
    (you only need the semicolon between two descriptions, not at the end)

    Try adding the semi-colon after '#3B28B4' and see if that helps .

  • #10
    New to the CF scene
    Join Date
    Jun 2002
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanx a lot guys!

  • #11
    Regular Coder
    Join Date
    May 2002
    Location
    Maine, USA
    Posts
    573
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by applesauce
    (you only need the semicolon between two descriptions, not at the end)

    Not needed, but a good practice IMO. If you add the semi-colon (which is required except for the exception you pointed out) you develop a good habit. Let's say, for example, he later wanted to add a different font-weight to his hover. If he just clicks behind 'background:#3B28B4' adds a space and adds 'font-weight: 700;', he'll have problems. Now probably he'd notice it and add the semi-colon, but it's safer to have added the semi-colon in the first place .
    boxer_1
    CodingForums Moderator
    "How did a fool and his money get together in the first place?"

  • #12
    Regular Coder
    Join Date
    Jun 2002
    Location
    Dallas, Texas
    Posts
    188
    Thanks
    0
    Thanked 0 Times in 0 Posts
    maybe, but it wouldn't have caused an error in his style.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •