I am having a problem with my dropline menu in IE6. Here's the CSS:

Code:
.menu {font-family: arial, sans-serif; height:98px; position:relative; float:left; margin:0; font-size:12px; background:#9cb5ca url(/EX07/images/buttons_bg.jpg) right repeat-y; z-index:100;}
.menu ul {padding:0; margin:0; list-style-type: none;}
.menu ul li {float:left; width:202px;}
.menu ul li a, .menu ul li a:visited {display:block; width:202px; text-decoration:none; height:98px; color:#fff; background:#9cb5ca url(/EX07/images/buttons_bg.jpg) right repeat-y;}
.menu table {border-collapse:collapse; margin:0; padding:0; font-size:1em; top:98px;}
.menu ul li ul {visibility:hidden; position:absolute; top: 98px; left:0; height:20px; text-align:center;}
.menu ul li ul li {height:20px; width:auto;  background:#4b4b4b;}
.menu ul li:hover ul {visibility:visible; width:600px; background:#4b4b4b; }
.menu ul li a:hover ul {visibility:visible; width:600px; background:#4b4b4b; color:#fff;}
.menu ul li:hover ul li a, .menu ul li a:hover ul li a {background:#4b4b4b; color:#fff; padding-right:12px; padding-left:12px; height:20px; width:auto; display:block;}
.menu ul li:hover ul li a:hover, .menu ul li a:hover ul li a:hover  {background:#7d96ac;}
And here's the HTML:
Code:
<div class="menu">
<ul>
<li><a href="#"><div style="margin-left:18px; padding-top:10px;"><img src="/EX07/images/Experience.png" width="139" height="25" alt="Experience" /><br />
		    <strong>Find out more about the<br />
		    Exponential Conference.</strong></div><!--[if IE 7]><!--></a><!--<![endif]-->
	<!--[if lte IE 6]><table><tr><td><![endif]-->
	<ul>
		<li><a href="/EX07/experience/faithraising/" title="Faithraising, Not Fundraising">Faithraising, Not Fundraising</a></li>
		<li><a href="/EX07/experience/model/" title="A Simple Model">A Simple Model</a></li>
		<li><a href="/EX07/experience/schedule/" title="Schedule">Schedule</a></li>
		<li><a href="/EX07/experience/impact/" title="What Others Have Said">What Others Have Said</a></li>
		<li><a class="lWOn" params="lWWidth=650,lWHeight=400" href="/EX07/experience/sponsors/" title="Expoential 2007 Sponsors">Sponsors</a></li>
	</ul>
	<!--[if lte IE 6]></td></tr></table></a><![endif]-->
</li>
</ul>
</div>
Anyone have any clues why its not working?