Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    May 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    IE textbox display problem, works in other browsers

    First the backstory.

    I just got a job as the webmaster for a company, right at the same time they upgraded their software. Because of the new software change I am updating the website to use the new shopping carts and such.

    To make a long story a little bit longer this website is really badly constructed, quite a bit of the site (like shopping carts) are restricted so I cannot modify them, and we are forced to do things like load CSS that is on their servers and we cannot modify (which if you run validation has about 600 warnings in it). To top it all off when I suggested the company let me get rid of tables and replace the formatting of the website with CSS they said no, its not an efficient use of my time. I have managed to get the site working decently well with what I have with the exception of this one page which has me stumped.

    The webpage in question is still up on our staging server and you can get to it here: https://staging.thecampushub.com/red...ount_login.asp

    The problem I am having with this is if you view the page in Firefox, Safari, Opera, etc. the page looks exactly like it should. If you view the page in IE it does not look like it should. I was hoping someone would be able to direct me to some answers.

    Also feel free to poke around the site and offer tips and suggestoins.

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Put background colors on those elements and see why they might be the way they are. Can you add anything to the document? If you can I would add this
    Code:
    <!--[if lte IE 6]>
    <style type="text/css">
    #account-login-email {
    margin-left:30px;
    display:inline;
    margin-top:15px;
    }
    #account-login-password {
    float:left;
    margin-top:15px;
    margin-left:30px;
    display:inline;
    }
    </style>
    <![endif]-->
    That fixes the issue in IE6. IE7 doesn't seem to have the issue. That would have to go after all of your other styles.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New Coder
    Join Date
    Feb 2007
    Location
    Albany, Oregon
    Posts
    66
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Looking at the code, I noticed that there was a <link> outside the head. That may be causing some problems. Don't know if you've tried, but attempting to validate the code (with the style sheet reference inside the head) returns 363 errors. Seems to me the site needs a redesign - without using tables for layout.

  • #4
    New to the CF scene
    Join Date
    May 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank Areo that did the trick!

    Zach, I agree the site needs a resdesign, some day perhaps I can convince my boss of that too.

  • #5
    Senior Coder koyama's Avatar
    Join Date
    Dec 2006
    Location
    Copenhagen, Denmark
    Posts
    1,246
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Quote Originally Posted by zach4618 View Post
    Looking at the code, I noticed that there was a <link> outside the head. That may be causing some problems.
    Not just is it placed outside the head section. It is placed before the document type declaration.

    This is causing the page to be rendered in quirks mode!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •