Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    May 2007
    Location
    Glasgow, Scotland
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy SSI HTML display problem

    Hi there,

    I'm a total noob to this and have kinda hit a stumbling block when doing my most recent project.

    Basically the navigation is setup using ssi, when certain pages load the navigation doesn't display correctly, however after I hit F5 it fixes itself.

    There doesn't seem to be any way to replicate it, it just happens on random pages.

    BEFORE http://img293.imageshack.us/img293/8...eloadedbc9.gif

    AFTER http://img293.imageshack.us/img293/4278/afterf5kf4.gif

    The pages can be accessed at
    http://www.colquhouns.org/index2.shtml

    Please shed some light on why this is happening and how i'm able to fix it.

    In anticipation.....

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    When you use ssi you don't include the doctype and everything inside of the include. You have done this. This is likely part of the problem. The other problems are you used tables for page layout. Read the link in my sig titled "Why Tables for Layout is Stupid?". Also read the sticky about doctypes.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New to the CF scene
    Join Date
    May 2007
    Location
    Glasgow, Scotland
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by _Aerospace_Eng_ View Post
    When you use ssi you don't include the doctype and everything inside of the include. You have done this. This is likely part of the problem. The other problems are you used tables for page layout. Read the link in my sig titled "Why Tables for Layout is Stupid?". Also read the sticky about doctypes.
    Thank you...that was a very quick response! i'll look into that


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •