Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 8 of 8
  1. #1
    New to the CF scene
    Join Date
    May 2007
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Please help with using css

    Hello, I have downloaded a template for zen-cart, an open source ecommerce site. Please visit my site sparkleshades.com/store.

    The problem i am having is customizing the template with my own images. The original header image that came with the template was 282px tall and mine is 255px. If you are using IE you will see that there is now a gap of 27px btwn the header image the the navigation image below it. Could someone please look at my css code and find what I would need to change so that the images below the header are moved up. Below are all of the lines of css code that would be associated with the index page:

    #mainWrapper {

    text-align: left;
    width: 842px;
    vertical-align: top;
    background-image: url(../images/mainwrapper_tile.jpg);
    background-repeat: repeat-y;
    background-position: center;
    }
    #logoWrapper {
    background-color: transparent;
    height:255px;
    }

    #headerWrapper {
    background-image: url(../images/header_bg.jpg);
    background-repeat: no-repeat;
    }
    #navMainWrapper {
    margin: 0em;
    margin-bottom: 0px;
    height: 26px;
    background-color: #989da3;
    font-weight: bold;
    color: #ffffff;
    padding: 15px;
    background-image: url(../images/nav_cat_bg.jpg);
    background-repeat: no-repeat;
    }

    Under #logoWrapper i changed the height from 282px to 255px and it worked but only in Opera and Firefox. In IE6 it doesnt work. What can I do? Thanks so much!

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Nothing is wrong with your CSS. We need to see a link to your page.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New to the CF scene
    Join Date
    May 2007
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Thanks, here is the link to the page:

    http://sparkleshades.com/store/

    Right below the black header and above the naviagtion image where "home" and "login in" is you will see the gray area. That is what I need to get rid of by moving all images below the header up 27px. I f you view it in opera or firefox you will not see the space. Thanks!

  • #4
    New to the CF scene
    Join Date
    May 2007
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Any guesses as to how I can code my css so that It will appear correct in IE? Thanks

  • #5
    Senior Coder effpeetee's Avatar
    Join Date
    Feb 2007
    Location
    Clapham Junction - London SW
    Posts
    4,885
    Thanks
    228
    Thanked 204 Times in 203 Posts
    Quote Originally Posted by grogo21 View Post
    Any guesses as to how I can code my css so that It will appear correct in IE? Thanks
    On my PC IE7 that band is a hyperlink.

    Had you noticed.

    effpeetee

  • #6
    Senior Coder koyama's Avatar
    Join Date
    Dec 2006
    Location
    Copenhagen, Denmark
    Posts
    1,246
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Hmm... I don't see the issue. Well, I see different renderings, but not related to the banner.

    Actually, the page looks better in IE6 than in Firefox, I would say.

    Can you be more specific what the problem is that you are seeing?

  • #7
    New to the CF scene
    Join Date
    May 2007
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Im sorry I was plaing around with the css and it most likly looked different when you looked at it. I got it to work with IE now but not Firefox or Opera. Ill keep playing with it until I get it. Thanks for looking though!

  • #8
    New Coder
    Join Date
    Apr 2007
    Posts
    72
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Hi:

    Tried to view your store at the link in your post. However, said page could not be found. Check to see if you uploaded your page correctly and I'll take a look back at the CSS for your images.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •