Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Feb 2007
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    centering text and button troubles

    I am attempting to modify a skin over on RunBoard.com and am having trouble getting the button and text to center properly in the following code snippet:

    /* NEW TOPIC & ADD REPLY BUTTONS */
    .topiclistpostnewtopic a {font-size:12px;font-family:verdana,tahoma;background-color:#000;background-image:url(http://img.runboard.com/img/layouts/defj_1/button.gif);background-repeat:no-repeat;border-color:#ffff00;letter-spacing:1px;padding:11px;padding-left:15px;padding-right:15px;}
    .postlistaddareply a {font-size:12px;font-family:verdana,tahoma;background-color:#000;background-image:url(http://img.runboard.com/img/layouts/defj_1/button.gif);background-repeat:no-repeat;border-color:#ffff00;letter-spacing:1px;padding:11px;padding-left:30px;padding-right:30px;}
    .ak_msgform_reply_added_table {border-collapse: collapse; border-width: 0px 0px 0px 0px;font-size: 18px; font-weight: 700; text-align:center; margin 0 auto;width: 90%}
    .ak_msgform_reply_added_td {text-align:center;margin: 0 auto;float:left;font-size:12px;font-family:verdana,tahoma;background-color:#000;background-image:url(http://img.runboard.com/img/layouts/defj_1/button.gif);background-repeat:no-repeat;border-color:#ffff00;letter-spacing:1px;padding:11px;padding-left:20px;padding-right:30px;}

    The first two classes are behaving correctly, the third class is there because it seems to be related somehow to the fourth class which is not behaving properly (the float:left declaration is a stopgap measure since the board is already in use).

    For some reason unless I have either float:left or float:right in the code the button graphic appears on the left side of the screen and the text is where it should be (ie: centered)... I am at a loss... does anyone have any ideas on how to tame the fourth class so it will behave like the first two classes?

    The board itself is: http://com2.runboard.com/bdesignelements but please bear in mind that I can only change/modify the existing "default CSS" from the comment /* ENERGY NON-STANDARD CSS CLASSES - STARTING MODIFICATIONS */ down...

  • #2
    Senior Coder koyama's Avatar
    Join Date
    Dec 2006
    Location
    Copenhagen, Denmark
    Posts
    1,246
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Hmm... I cannot find the buttons you are talking about. Where are the elements?

  • #3
    New Coder
    Join Date
    Feb 2007
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    The button

    Hi,

    There is only one button image located here: http://img.runboard.com/img/layouts/defj_1/button.gif

    What I am doing is placing the appropriate text on the button image and as I said, this is working correctly for the first two classes but I can not seem to figure out why it doesn't work for the final class...


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •