Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Dec 2006
    Location
    College Station
    Posts
    26
    Thanks
    0
    Thanked 0 Times in 0 Posts

    link color problems

    Hey guys,

    I'm just starting out in coding, and I am going through the usual cross-platform compatibility issues--this time with link styles. I am using CSS to try to get rid of the underline and to set the color of the link, and it works fine on my system (FF 2.0) but not on a friend's Apple (Safari) or another friend's FF 1.8 system. It does work on a third FF 1.8 system...

    Here's the page:

    http://derbydigitalphoto.com/test/index.php


    Thanks for your help!
    --Daniel

  • #2
    Senior Coder
    Join Date
    Jan 2005
    Location
    Memphis, TN
    Posts
    1,785
    Thanks
    8
    Thanked 131 Times in 129 Posts
    Code:
    a:link, a:visited, a:active {text-decoration: none; color:#818181}
    a:hover {text-decoration: none; color:#e455a0}
    try that.

    your not defining a visited stae so the current page or any one you've previously visited are resorting back to default values.
    Stop making things so hard on yourself.
    i is tugbucket :: help raise tugburg :: Whitehaven Kiwanis

  • #3
    New Coder
    Join Date
    Dec 2006
    Location
    College Station
    Posts
    26
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks! That fixed it.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •