I have been working on last couple of full CSS layout sites without any problems but this is first time I'm working on 100% width CSS layout and I realised it wasn't easy!

I'm using PHP Simple Gallery and integrate it into testing template to see if it works. It worked fine in fixed width sites before but not this one.

Problem 1: Missing content in Internet Explorer
http://www.udsc.org.uk/gallery/template.php

It shows fine in Firefox but in Internet Explorer, content is missing and if you put mouse over it, it will show up! Strange issue, I don't know what is causing this?

Problem 2: Light blue background not extended to the bottom in Firefox
http://www.udsc.org.uk/gallery/templ...sary%20Weekend

Light blue background show all the way to bottom in Internet Explorer but not in Firefox, how to extend that just like in IE?

Note the missing heading title which is probably due to Problem 1 for Internet Explorer.

Problem 3: Missing content in static pages such as contact us page in Internet Explorer
http://www.udsc.org.uk/contactus.php

It's fine in Firefox but missing content in IE.

Bit similar to problem 1, however, this time it's due to Cutenews. There is 100% width on 'Content Management Powered by CuteNews' which caused this problem and it cannot be hacked with to remove 100% so how to work out around this? I have saved it as html page to desktop and removed 100% width and content shows up fine just to confirm that.

Working on fixed width CSS layouts have been fine for me but not with 100% width this time! I guess that if these can not be solved then I might go for simple table to avoid these problems.

Thanks in advance