Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 15 of 15

Thread: Play once?

  1. #1
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Play once?

    Hi peeps,

    I'm having a problem getting a sound bite to play "ONCE". Heres the Link: http://www.mcd4x4.com/nypd/hwy5.htm I've tried everything I can think of, but it's beaten me up tonight. Thanks.
    BrianNY/Rookie

  • #2
    Regular Coder
    Join Date
    Feb 2003
    Posts
    345
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I don't have Flash installed right now, but there is an option somewhere in the program to play audio just once, or you can just try to stop the movie at the end of the frames avoiding the loop.

  • #3
    New to the CF scene
    Join Date
    Sep 2003
    Location
    Far away
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yes, when you add a sound to your flash movie file, you can click on it's properties (in the bottom of the page by default) and it's an option that you can stop the sound from being repeated. You can also stop() in the end of your clip as an action that your player doesn't loop back.

    But as I noticed you're only using the flash file for playing the syrenning sound, right? Why are you doing it? You can do it with HTML to, no need to use flash.

    Also I think the loop effect that you have for syrenning sound. I didn't like it if it played just once!

  • #4
    Senior Coder
    Join Date
    Mar 2003
    Location
    Atlanta
    Posts
    1,037
    Thanks
    14
    Thanked 30 Times in 28 Posts

    Cool

    I would help out but unfortunately I have a different outlook on the ppl who "keep us safe."
    Most of my questions/posts are fairly straightforward and simple. I post long verbose messages in an attempt to be thorough.

  • #5
    Senior Coder
    Join Date
    Mar 2003
    Location
    Atlanta
    Posts
    1,037
    Thanks
    14
    Thanked 30 Times in 28 Posts
    Okay okay. I'll help.

    Why don't you just save the mp3., wma or whatever audio file you are using directly on the server and simply use BGSOUND SRC. as NoName suggested? Such as:

    <bgsound src="filepath" loop="1">

    filepath meaning where you saved your audio file.

    Can you tell them to stop pulling me over now. I really can afford a Mercedes.
    Most of my questions/posts are fairly straightforward and simple. I post long verbose messages in an attempt to be thorough.

  • #6
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    maybe I'm doing something wrong, please take a look. With the above code it's not playing at all. http://www.mcd4x4.com/NYPD5/hwy.htm
    BrianNY/Rookie

  • #7
    Senior Coder
    Join Date
    Mar 2003
    Location
    Atlanta
    Posts
    1,037
    Thanks
    14
    Thanked 30 Times in 28 Posts
    Yes actually this code cannot be associated with a flash document. It is to be used with either a wav,mp3,mp2, or wma actual audio files.

    What you have is an audio file embedded into a flash file. Do you have the actual audio? If not I'll be a nice guy and extract it out for you. But if you do have the actual audio file use that and it will work fine.
    Most of my questions/posts are fairly straightforward and simple. I post long verbose messages in an attempt to be thorough.

  • #8
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks. That worked. I used an MP3. Do you have a preference as to which file types are better for this application? MP3 or WAV? Thanks again.
    BrianNY/Rookie

  • #9
    Senior Coder
    Join Date
    Mar 2003
    Location
    Atlanta
    Posts
    1,037
    Thanks
    14
    Thanked 30 Times in 28 Posts
    Definately keep it as MP3. A wav file will take to long to load being that it maybe 10 times the file size. Since this is for a webpage you don't need the extra rendering that is in a wav file. You can't hear the difference. Good luck. And if ever need help I'm here. One thing I forgot to say if it does not start (the mp3) when the page loads you might want to put an additional attribute:


    autostart="true"
    Most of my questions/posts are fairly straightforward and simple. I post long verbose messages in an attempt to be thorough.

  • #10
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello "again"

    Where would I put this.. autostart="true"? On the same line before it, above or below it. Thanks. I do appreciate the help.
    BrianNY/Rookie

  • #11
    Senior Coder
    Join Date
    Mar 2003
    Location
    Atlanta
    Posts
    1,037
    Thanks
    14
    Thanked 30 Times in 28 Posts
    it will be in the same BG tag.

    <bgsound src ="xxxxxx.mp3" loop ="1" autostart ="true">

    Autostart is an attribute of the BGSOUND tag. Everything highlighted in royalblue is an attribute of the BGSOUND tag. There are other attributes of the BGSOUND tag that you can maniputate. You probaly can google and find different attributes of this and other HTML tags.
    Most of my questions/posts are fairly straightforward and simple. I post long verbose messages in an attempt to be thorough.

  • #12
    Senior Coder
    Join Date
    Mar 2003
    Location
    Atlanta
    Posts
    1,037
    Thanks
    14
    Thanked 30 Times in 28 Posts
    P.S. the order of the attributes do not matter as long as they are after the tag and you have the values enclosed in parenthesis.
    Most of my questions/posts are fairly straightforward and simple. I post long verbose messages in an attempt to be thorough.

  • #13
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for your time Ralph, I appreciate the help.
    BrianNY/Rookie

  • #14
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    new post posted
    Last edited by MCD4x4; 10-12-2003 at 04:36 PM.
    BrianNY/Rookie

  • #15
    Senior Coder
    Join Date
    Mar 2003
    Location
    Atlanta
    Posts
    1,037
    Thanks
    14
    Thanked 30 Times in 28 Posts
    [QUOTE]Originally posted by StupidRalph
    P.S. the order of the attributes do not matter as long as they are after the tag and you have the values enclosed in parenthesis. [ /QUOTE]

    DOUGH!!! Enclosed in quotation marks.
    Last edited by StupidRalph; 10-13-2003 at 04:59 PM.
    Most of my questions/posts are fairly straightforward and simple. I post long verbose messages in an attempt to be thorough.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •