Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Aug 2010
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    ? with IE and SWF embeding

    Hello all,

    Well I'm having issues with a homepage I'm creating, everytime I load it on IE, I get an Active X warning on top of the page because I'm running a Flash on the homepage.

    My question is, is there a way to get rid of that (active x) and if so can some one explain it to me please. The same thing happens with spry elements.

    If it helps I do all my coding with Dreamweaver CS5.

    Here is my HTML code

    Code:
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <!-- TemplateBeginEditable name="doctitle" -->
    <title>Untitled Document</title>
    <!-- TemplateEndEditable -->
    <!-- TemplateBeginEditable name="head" -->
    <!-- TemplateEndEditable -->
    <link href="../CSS/Index.css" rel="stylesheet" type="text/css" />
    <script src="Scripts/swfobject_modified.js" type="text/javascript"></script>
    <style type="text/css">
    a:link {
    	text-decoration: underline;
    	color: #333;
    }
    a:visited {
    	text-decoration: underline;
    	color: #333;
    }
    a:hover {
    	text-decoration: none;
    	color: #F39;
    }
    a:active {
    	text-decoration: underline;
    	color: #000;
    }
    </style>
    <OBJECT
    		codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0"
    		width="1000" height="250" ALIGN="">
    		<PARAM NAME=movie VALUE="/css-files/flashbanner.swf">
    		<PARAM NAME=quality VALUE=high>
    		<param name=wmode value=transparent>
    		<EMBED src="/css-files/flashbanner.swf" quality=high  wmode="transparent"  width="1000" height="250" ALIGN=""
    		TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED> 
    		</OBJECT>
    </head>
    
    <body text="#333333" vlink="#FF3399">
    
    
    <div class="container">
      <div class="content">
      <script type="text/javascript" src="scripts/swfobject.js"></script>
      <table width="400" border="0" align="center">
      <tr>
        <td>&nbsp;</td>
      </tr>
      <tr>
        <td><object id="FlashID" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="300" height="250">
          <param name="movie" value="../../Media/gina1.swf" />
          <param name="quality" value="high" />
          <param name="wmode" value="transparent" />
          <param name="swfversion" value="6.0.65.0" />
          <!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you don’t want users to see the prompt. -->
          <param name="expressinstall" value="Scripts/expressInstall.swf" />
          <param name="LOOP" value="false" />
          <!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
          <!--[if !IE]>-->
          <object type="application/x-shockwave-flash" data="../../Media/gina1.swf" width="300" height="250">
            <!--<![endif]-->
            <param name="quality" value="high" />
            <param name="wmode" value="transparent" />
            <param name="swfversion" value="6.0.65.0" />
            <param name="expressinstall" value="Scripts/expressInstall.swf" />
            <param name="LOOP" value="false" />
            <!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
            <div>
              <h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
              <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
            </div>
            <!--[if !IE]>-->
          </object>
          <!--<![endif]-->
        </object></td>
      </tr>
    </table>
    
    <table width="400" border="0" align="center">
      <tr>
        <td width="400" height="25"><a href="About US.htm">Enter Site</a></td>
        <td>&nbsp;</td>
        <td width="400" height="25"><a href="Nosotros.html">Entrar</a></td>
      </tr>
    </table>
      <!-- end .content -->
      </div>
    <!-- end .container --></div>
    <script type="text/javascript">
    swfobject.registerObject("FlashID");
    </script>
    </body>
    </html>

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    That warning will only show locally. Once you put it on a server it will run fine with no warning.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • Users who have thanked _Aerospace_Eng_ for this post:

    ahsesino (08-04-2010)

  • #3
    New to the CF scene
    Join Date
    Aug 2010
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thank you on the prompt reply,

    I'm still a web design and development student and this is my first design going out to the web.

    Again thank you very much.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •