Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Mar 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Conflict between JS and Animated Gifs

    Hi guys,
    I have created a transparent animated header usig flash cs3 which loops continiously. flash has automaticaly created a javascript link to this animation. I also have some animated gifs on my html body. for some reason the animated gifs freezes every few seconds. I also noticed that if i remove the javascript link from the head of html all the animated gifs works fine but ofcourse the header animation does'nt. Is there any way i can resolve this issue so that all animations works fine? Please help.

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Post a link to your site.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New to the CF scene
    Join Date
    Mar 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi, sorry for the late reply. for some reason it works fine now. it only happened in IE. I realy dont know whats happening with it. But nice to know some feed back in case if it happens in the future. yesterday when it happened I tried something different and it worked OK. all I did was took the javascript out from the head tag and inserted it in the DIV tag where the flash animation is. and it all worked fine. So now my question is, Is it ok to put
    <script type="text/javascript" src="Scripts/AC_RunActiveContent.js"></script>
    under a div tag rather than under the head.

    I am new to all this so any advise will help me in future.

    the link to my site is:
    http://www.net2net.co.uk/electro/products.html

    thanks again

  • #4
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Its okay, its there so its available when the page loads. Sometimes depending the script the element needs to exist before the javascript can even work. The script you are using waits until the page has loaded before it starts running. I can't load your site.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #5
    New to the CF scene
    Join Date
    Mar 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    ok I get it. Why you can't load my site. the link is the same and it works. Thanks for your help.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •