Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    Regular Coder
    Join Date
    Nov 2003
    Location
    Bloomsbury, London
    Posts
    102
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Question All hyperlinks in blog posts have stopped working all of a sudden

    We're using the latest version of Wordpress (installed on our site).

    Not had an issue with hyperlinks in the blog posts of our blog before - the links have worked correctly for several years; however, they have suddenly stopped working property.

    Instead of hyperlinks to external webpages sending people to the correct URLs, every link directs people to our homepage.

    You can see the non-functioning links in our blog posts here.

    I'm scratching my head trying to work out what could be causing this. Any help would be greatly appreciated. Thank you in advance.
    Domain Exhibit - premium domain names and websites with significant traffic | quote Coding Forums for additional 15% discount!
    Coding Freebies - free scripts and software worth hundreds of dollars

  • #2
    Regular Coder
    Join Date
    Mar 2013
    Posts
    262
    Thanks
    4
    Thanked 67 Times in 67 Posts
    What does your .htaccess file look like?

  • #3
    Regular Coder patryk's Avatar
    Join Date
    Oct 2012
    Location
    /dev/couch
    Posts
    398
    Thanks
    2
    Thanked 64 Times in 64 Posts
    well instead of scratching your head, check calendar (just a thought)
    it works just fine in my browser

    and btw check this one: https://www.google.com/intl/en/landing/nose/

    ---edit---
    sorry... i clicked on right menu... it doesn't work on my side either.
    Last edited by patryk; 04-01-2013 at 06:23 PM.

    -------------------------------------------------------------------------------
    "Real Programmers can write assembly code in any language" - Larry Wall

  • #4
    Regular Coder
    Join Date
    Nov 2003
    Location
    Bloomsbury, London
    Posts
    102
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Thanks for the help.

    I wish it was an April Fool's joke () but I've checked on different computers and in different browsers and the external hyperlinks don't work. Don't have an issue with the links on any other website.

    RE: the .htaccess it's very long, but I've copied the relevant code below for the link cloaking bit (yes, the 'Link Cloaker Plugin' code is there twice), in case you think that may be causing the issue. However, I haven't changed the .htaccess for ages, so not sure why the links would stop working properly all of a sudden. When I click on them, they just send me to the home page i.e. www.azam.info

    # BEGIN WordPress

    # Link Cloaker Plugin BEGIN
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule goto/([^/]*)/([0-9]+)/([0-9]+)/? http://www.azam.info/wp-content/plugins/link-cloaking-plugin/wplc_redirector.php?post_id=$2&link_num=$3&cloaked_url=$0 [L]
    RewriteRule goto/([^/]+)[/]? http://www.azam.info/wp-content/plugins/link-cloaking-plugin/wplc_redirector.php?name=$1&cloaked_url=$0 [L]
    </IfModule>
    # Link Cloaker Plugin ENDS

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    # BEGIN 301 redirect of azam.info to www.azam.info
    Options +FollowSymlinks
    RewriteEngine on
    rewritecond %{http_host} ^azam.info [nc]
    rewriterule ^(.*)$ http://www.azam.info/$1 [r=301,nc]
    # END 301 redirect of azam.info to www.azam.info

    # Link Cloaker Plugin BEGIN
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule goto/([^/]*)/([0-9]+)/([0-9]+)/? http://www.azam.info/wp-content/plugins/link-cloaking-plugin/wplc_redirector.php?post_id=$2&link_num=$3&cloaked_url=$0 [L]
    RewriteRule goto/([^/]+)[/]? http://www.azam.info/wp-content/plugins/link-cloaking-plugin/wplc_redirector.php?name=$1&cloaked_url=$0 [L]
    </IfModule>
    Domain Exhibit - premium domain names and websites with significant traffic | quote Coding Forums for additional 15% discount!
    Coding Freebies - free scripts and software worth hundreds of dollars

  • #5
    Regular Coder patryk's Avatar
    Join Date
    Oct 2012
    Location
    /dev/couch
    Posts
    398
    Thanks
    2
    Thanked 64 Times in 64 Posts
    well i'm going stupid here now. it DOES work in my firefox (and it didn't 5 minutes ago)
    for example i click crossword and it takes me to http://www.azam.info/category/business/

    -------------------------------------------------------------------------------
    "Real Programmers can write assembly code in any language" - Larry Wall

  • Users who have thanked patryk for this post:

    Azam.net (04-01-2013)

  • #6
    Regular Coder
    Join Date
    Nov 2003
    Location
    Bloomsbury, London
    Posts
    102
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Thank you for checking. Yes, that's an internal link. I was referring to external hyperlinks.

    I've disabled the 'Link Cloaker' plugin and the external links work fine now.

    Thank you once again for the help!
    Domain Exhibit - premium domain names and websites with significant traffic | quote Coding Forums for additional 15% discount!
    Coding Freebies - free scripts and software worth hundreds of dollars

  • #7
    Regular Coder
    Join Date
    Mar 2013
    Posts
    262
    Thanks
    4
    Thanked 67 Times in 67 Posts
    Well, first, I don't really understand why it's repeated twice either. That's just weird. I would take out the section between

    # BEGIN WordPress
    # END WordPress

    That section is generally reserved for WordPress. For example, if you change your permalinks structure, WordPress will rewrite that section, which will effectively erase the Link Cloaker Plugin section anyway. ...So take out the first Link Cloaker Plugin section but keep the second one.

    That second section should also have a..

    # Link Cloaker Plugin ENDS

    Edit: Oh ok. Never mind. ><

  • Users who have thanked ttkim for this post:

    Azam.net (04-01-2013)


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •