Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Sep 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Facebook Like Button won't publish the correct picture

    I have scoured the Internet trying to find solutions for this and have tried multiple options trying to get this all to work. I have set up like/share buttons on my website. I used META TAGS to direct the published picture to a specific image because I couldn't get it to actually pull the right image off the website. So one picture for every item is fine.

    The "Share" button on the website works and reflects the logo that I directed it to, but the "Like" button still wants to use the incorrect picture. My button code looks like this:

    www.hollywoodhistoryonline.com


    <link rel="image_src" href="http://hollywoodhistoryonline.com/hollywoodhistoryonline.com/FB.JPG" />
    <!-- AddThis Button BEGIN --><div class="addthis_toolbox addthis_default_style ">
    <a class="addthis_button_facebook_like" fb:like:layout="button_count"></a>
    <a class="addthis_button_tweet"></a>
    <a class="addthis_button_pinterest_pinit"></a>
    <a class="addthis_counter addthis_pill_style"></a>
    </div>
    <script type="text/javascript" src="http://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-505ba5d06c53a358"></script>
    <!-- AddThis Button END -->
    </div>


    And metas look like this:

    <meta property="og:title" content="<?php echo META_TAG_FACEBOOK; ?>" />
    <meta property="og:type" content="product" />
    <meta property="og:url" content="<?php echo $canonicalLink; ?>" />
    <meta property="og:description" content="<?php echo $meta_products_description; ?>" />
    <meta property="og:site_name" content="<?php echo STORE_NAME; ?>" />
    <meta property="fb:admins" content="508187323" />
    <meta property="og:image" content="http://hollywoodhistoryonline.com/hollywoodhistoryonline.com/FB.JPG" />


    What am I doing wrong? All the other information is populating correctly as coded, even though I would rather use the Item title + Price instead of the webpages title like: http://www.hollywoodhistoryonline.co...roducts_id=409

    I would wanted it to publish as Hogwart's Invitation Envelope - $800. Currently it would read like this: Hogwart's Invitation Envelope [1070a] - $800.00 : Hollywood History Online, Discover the Magic and B...

    Which is entirely too long, but then again that's when I click "Like" but the "Share" button doesn't put that much information in there, it's much cleaner. Any suggestions? Thanks.

  • #2
    New to the CF scene
    Join Date
    Sep 2012
    Location
    India
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    This should work i dont know the reason why it is not working i used the same code....

  • #3
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,624
    Thanks
    6
    Thanked 1,001 Times in 974 Posts
    It could be that the image is stored in Facebook’s cache memory and it will take a while for it to be updated. I seem to remember that I once had the same problem.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •