Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5

Thread: webpage errors

  1. #1
    Regular Coder
    Join Date
    Apr 2008
    Location
    New York
    Posts
    142
    Thanks
    1
    Thanked 0 Times in 0 Posts

    webpage errors

    http://validator.w3.org/check?uri=ht...Inline&group=0

    what can I do to correct these errors. I'm confused

  • #2
    Master Coder
    Join Date
    Jun 2003
    Location
    Cottage Grove, Minnesota
    Posts
    9,500
    Thanks
    8
    Thanked 1,089 Times in 1,080 Posts
    It's really hard to get blogs to validate because things get inserted
    by content that's added. In your case, most of the & ampersands.
    If you made them all, & ... instead of "&", you would eliminate
    many of the errors.

    That happens because of URL's that get added to the content.

    Javascripting is another touchy area.

    With WordPress, you may not ever get it to validate.

  • #3
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    Really? As far as my experiences with WordPress go, they're pretty valid. I've let my friend have free lease with a blog I designed for her and it's remained valid to this date.

  • #4
    Senior Coder gnomeontherun's Avatar
    Join Date
    Sep 2007
    Location
    Houston
    Posts
    2,846
    Thanks
    10
    Thanked 238 Times in 229 Posts
    I think it depends on what plugins you use, what template you use, and if the designers gave 2 cents about validation. It has the ability to be valid, if the themes and plugins support it. That being said, its still hard to manage valid content with automated systems. It requires checking after everypost!
    jeremy - gnomeontherun
    Educated questions often get educated answers, and simple questions often get simple answers.

  • #5
    Master Coder
    Join Date
    Jun 2003
    Location
    Cottage Grove, Minnesota
    Posts
    9,500
    Thanks
    8
    Thanked 1,089 Times in 1,080 Posts
    I see their link variables use & (ampersands),
    whereas, CyanLights pages uses #.

    So there must be some sort of conversion somewhere, in a plugin or .htaccess?

    & won't validate.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •