Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Aug 2007
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question IE problems with script

    Could someone look at www.skypix.biz source code and tell me why it runs in Firefox but not IE7. Not even a gray box or red check. Nothing. But again, works in Firefox and Opera I believe.

  • #2
    Regular Coder BabyJack's Avatar
    Join Date
    Apr 2008
    Location
    Somewhere.
    Posts
    602
    Thanks
    43
    Thanked 6 Times in 6 Posts
    Im not so sure what you mean. Im looking at the source and what do you mean by the 'Gray Box or Red Check?'
    Enlightenment in Coding
    Validate before Posting | Google is your friend for PC Problems | Make sure you have a doctype

  • #3
    New to the CF scene
    Join Date
    Aug 2007
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Sorry. I meant in IE, nothing is there. You can see the background. Sometimes when looking at a webpage and the image is not linked properly or not on the server, there is a box with a red check. But that doesn't even appear. The gray box, the color of the script application is gray so I thought even that would appear if the script would not run. Nope. Again nothing shows in IE. In Firefox, the script works normally.

  • #4
    Regular Coder BabyJack's Avatar
    Join Date
    Apr 2008
    Location
    Somewhere.
    Posts
    602
    Thanks
    43
    Thanked 6 Times in 6 Posts
    Oh OK, yes the script is running fine in FF and failed to load in IE. Sorry, probably just browser differences or the script having some line of code in to make it not work on IE. I think it is stupid. All things should work on all browsers. Infact - why not have 1 browser?!
    Enlightenment in Coding
    Validate before Posting | Google is your friend for PC Problems | Make sure you have a doctype

  • #5
    New to the CF scene
    Join Date
    Aug 2007
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I should add that I had a flip book script from dynamic drive there before and it worked in both IE and FF, albeit it looked better in FF. This morning, I changed it to a flash-type flipbook. Like I stated, it is working in FF but not even showing in IE.

    I inserted the code just like www.thecountryfriends.org. I looked at their site in IE and the flip book works. So it is making no sense to me.

  • #6
    Master Coder mlseim's Avatar
    Join Date
    Jun 2003
    Location
    Cottage Grove, Minnesota
    Posts
    9,389
    Thanks
    8
    Thanked 1,077 Times in 1,068 Posts
    My guess is that it was saved wrong, and now all of the carriage returns
    are messed up. IE is having a problem parsing the HTML, especially the
    Javascripting and embedded code.

    Load it back to your PC in "binary" and save as "binary", not ASCII mode.
    Something to do with your FTP program or text editor.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •