Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Jan 2003
    Posts
    39
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Trouble with Tables

    I'm totally frustrated and hoping that one of you can help. So, here's the deal. I'm trying to build a web site that consists ofa white table on a grey background, with an image on the right hand side (ala gettyimages). The trouble is the right-hand cell (the one in which I have an image) has a bit of extra white space around it (or blue, or yellow, or whatever color I code in for the background color. The cell is 304 pixels wide, as is the image that I'm inserting. Below is the code? Any suggestions?

    BTW - as per on of your suggestions, I went to tucows and downloaded coffeecup html. Thanks for the idea.

    <body bgcolor="#66666" text="#333333" link="#008000" vlink="#008000" alink="#008000">
    <CENTER>
    <TABLE WIDTH="100%" HEIGHT="100%" >
    <TR VALIGN="MIDDLE" ALIGN="CENTER"><TD >

    <TABLE WIDTH="700" CELLSPACING="0" CELLPADDING="0" border="0">

    <tr><!-- Row 1 -->
    <td width="394" bgcolor="ffffff" > </td><!-- Col 1 -->
    <td width="304" bgcolor="ffffff" ><img src="images/rapper.jpg" width="304" height="378" border="0" align="right"> </td><!-- Col 2 -->
    </tr>

    </TABLE>
    </TABLE>

    </CENTER>
    </BODY>

    Thanks,
    MaFunk

  • #2
    Senior Coder
    Join Date
    Jun 2002
    Location
    The Netherlands, Baarn, Ut.
    Posts
    4,253
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Cell widths

    I tried ditching cell dimensions on the cell holding the image, and forcing the adjacent cell to match up width a width="100%" setting; no background color visible... Dunno if the forcing bit works on every browser, though.

    P.S. Oh, and the extra space after the img element might cause trouble as wel; I removed it, anyway.
    Last edited by ronaldb66; 01-16-2003 at 10:35 AM.
    Regards,
    Ronald.
    ronaldvanderwijden.com

  • #3
    New Coder
    Join Date
    Oct 2002
    Location
    California
    Posts
    98
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I found a few things that could be causing problems...

    <TR VALIGN="MIDDLE" ALIGN="CENTER"><TD >

    Add the attributes to TD not TR.

    <td width="304" bgcolor="ffffff" ><img src="images/rapper.jpg" width="304" height="378" border="0" align="right"> </td>

    remove the space between the img src and </td>

    hope this helps!

  • #4
    Regular Coder
    Join Date
    Jun 2002
    Posts
    676
    Thanks
    1
    Thanked 0 Times in 0 Posts
    maf...
    "quote...<TABLE WIDTH="700" CELLSPACING="0" CELLPADDING="0" border="0">

    <tr><!-- Row 1 -->
    <td width="394" bgcolor="ffffff" > </td><!-- Col 1 -->
    <td width="304" bgcolor="ffffff" >...endquote"

    ummm your 'tds' only just a total® 698 n' youve got your 'table' set to be 700...
    n' tooo???
    you just a forgot® the # infront of the ffffff

    n' just a nother® tooo???
    dont have just a linebreak® between your td's...
    aka...
    <tr><td>yadda yadda...</td><td>img goes here...</td></tr>

    just a goodluck® :O)))

  • #5
    New Coder
    Join Date
    Jan 2003
    Posts
    39
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thanks for the Suggestions

    You guys are awesome! Thanks for the suggestions. I tried all of them, and changed the code to "align="absright". Whala! It's all set.

    Thanks again.

    MDF


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •