Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Dec 2002
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question .htaccess/hot linking images problem

    I have set up the .htaccess to block the use of images from my website and replaces the image with a "special" one I created. It works perfectly....but I have a user at a message board, which I have hosted there, getting the special image while visiting the board. He is the only person complaining of this. What could be his/my problem?

    I set mine up like this:

    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http://your_domain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.your_domain.com/.*$ [NC]
    RewriteRule .*\.(gif|GIF|jpg|JPG)$ http://your_server.com/bad.gif [R]

  • #2
    Supreme Overlord Spookster's Avatar
    Join Date
    May 2002
    Location
    Marion, IA USA
    Posts
    6,273
    Thanks
    4
    Thanked 83 Times in 82 Posts
    HTTP_REFERRER is unreliable at best. It depends on information given to it from the browser. Not all browsers either give that information or give it corrrectly. Find out what browser and version they are using.
    Spookster
    CodingForums Supreme Overlord
    All Hail Spookster

  • #3
    New to the CF scene
    Join Date
    Dec 2002
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    He is using IE 6.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •