Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Apr 2009
    Posts
    0
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Buggy/hostile behavior when viewing CodingForums threads

    This does not happen EVERY time, but it has happened often.

    I have navigated to a thread from google, such as
    http://codingforums.com/showthread.php?t=68185

    As I am viewing the page, characters like short vertical bars on a green background begin to appear on the page.....slowly pushing the rest of the content lower.....it appears like some script (from an ad, perhaps) is generating spam characters and inserting them at the top of the page in some javascript loop that makes the browser VERY unresponsive.

  • #2
    New to the CF scene
    Join Date
    Apr 2009
    Posts
    0
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Apparently the actual text output is <span class="hilite1"></span> - I've got HUGE numbers of those in a text file I saved.

    Loading the text file CAUSES the behavior in FF, but IE7 shuts down the script.

  • #3
    Supreme Overlord Spookster's Avatar
    Join Date
    May 2002
    Location
    Marion, IA USA
    Posts
    6,278
    Thanks
    4
    Thanked 83 Times in 82 Posts
    Are you sure you don't have a virus or adware trojan on your PC? Does this just happen on your PC or also on other PC's you've tried?
    Spookster
    CodingForums Supreme Overlord
    All Hail Spookster

  • #4
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,624
    Thanks
    6
    Thanked 1,001 Times in 974 Posts
    Quote Originally Posted by Spookster View Post
    Are you sure you don't have a virus or adware trojan on your PC?
    Yeah, this was the first thing I’ve tought of, reading this.

  • #5
    WA
    WA is offline
    Administrator
    Join Date
    Mar 2002
    Posts
    2,596
    Thanks
    2
    Thanked 19 Times in 18 Posts
    What browser are you using? The text:
    Code:
    <span class="hilite1"></span>
    is actually something added by a script to highlight the searched terms when coming in from Google. For example, if you were to search for "codingforums ajax" on Google, upon visiting the resulting page on CF, the term Ajax would be highlighted:



    What you're describing could be the script going haywire, though in all the major browsers, I haven't experienced any issues.
    - George
    - JavaScript Kit- JavaScript tutorials and 400+ scripts!
    - JavaScript Reference- JavaScript reference you can relate to.

  • #6
    New to the CF scene
    Join Date
    Apr 2009
    Posts
    0
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Can't be sure there are no infections, but there certainly aren't any other signs of one - this has been the only place I've had a problem.

    Of course, it might be the script doesn't play well with other items I have installed, such as Imacros and Firebug.


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •