Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Feb 2005
    Posts
    29
    Thanks
    0
    Thanked 0 Times in 0 Posts

    black movie in flash

    I have made a Flash based website, and everything has a black background with white font. All the HTML pages are controlled by CSS.

    The body tag, has a black background, and the DIV that the flash movie sits in is set to black background.

    There is one point of the movie where it uses the getURL action to load another HTML page that contains another movie that is black. However, the DIV that contains the movie flashes WHITE just before the SWF loads.

    This sucks, and it's very disruptive. Surely there's a way to fix this. I have tried even just making a one frame movie with no content, and it still flashes white. So there's nothing directly in my movie that could be causing it.

    Anyone have any ideas?

  • #2
    Senior Coder TheShaner's Avatar
    Join Date
    Sep 2005
    Location
    Orlando, FL
    Posts
    1,126
    Thanks
    2
    Thanked 40 Times in 40 Posts
    My guess would that be that it's a wrapper element that probably has not had its background color set to black and the flash of white is the white background of this element before the div loads with the movie. Before the movie loads, the div will not be filled out and so the background element will be showing. Would you be able to post the HTML portion of the page?

    -Shane

  • #3
    New Coder
    Join Date
    Feb 2005
    Posts
    29
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the quick response. Yes, that's what I thought too, but I think I have everything covered. If I take the SWF out of the HTML page, it all shows up as black.

    Anyway, here's the HTML

    [CODE]/* CSS */
    body, form
    {
    margin: 0;
    padding: 0;
    border: 0;
    }

    body,td
    {
    background: #000000;
    font-family: Verdana, Sans-Serif;
    font-size: 9px;
    line-height: 11px;
    }


    #container
    {
    background-color: #000000;
    margin: 28px auto 0 auto;
    text-align: left;
    width: 758px;
    color: #CCCCCC;

    }
    #head
    {
    width: 755px;
    height: 30px;
    }

    #textnav
    {
    text-align: left;
    }

    #foot
    {
    width: 758px;
    text-align: center;
    margin-top: 8px;
    }

    #foot ul
    {
    display: inline;
    margin: 0;
    padding: 0;
    }

    #foot ul li
    {
    display: inline;
    list-style: none;
    margin: 0;
    padding: 0 8px 0 8px;
    }


    /* links */
    A:link, A:visited, A:active
    {
    color: #FFFFFF;
    background: transparent;
    text-decoration: none;
    }

    A:hover
    {
    color: black;
    background: #FFFFFF;
    text-decoration: none;
    }

    /* Dealer Page Style */

    #dealers td

    {
    color: #FFFFFF;
    }

    #dealers A:link, A:visited, A:active
    {
    color: #FFFFFF;
    background: transparent;
    text-decoration: none;
    font-size:10px;
    }

    #dealers A:hover
    {
    color: #FFFFFF;
    background: transparent;
    text-decoration: none;
    text-decoration: underline;
    font-size:10px;
    }

    H1
    {
    color: #FFFFFF;
    font-size: 14pt;
    text-decoration : none;
    }

    H2
    {
    color: #FFFFFF;
    font-size: 12pt;
    text-decoration : none;
    }
    Last edited by batch; 12-05-2005 at 06:48 PM.

  • #4
    New Coder
    Join Date
    Feb 2005
    Posts
    29
    Thanks
    0
    Thanked 0 Times in 0 Posts
    and here's the HTML

    [CODE]<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <title></title>
    <link href='globalstyle.css' rel='stylesheet' type='text/css' />
    </head>
    <body>
    <div id="container" align="center">
    <object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="700" height="600">
    <param name="movie" value="movie.swf" />
    <param name="quality" value="high" />
    <embed src="movie.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="700" height="600"></embed></object>
    </div>
    </body>
    </html>

  • #5
    New Coder
    Join Date
    Feb 2005
    Posts
    29
    Thanks
    0
    Thanked 0 Times in 0 Posts
    well after much searching I finally found the answer to this seemingly rediculous oversite by the folks at Macromedia. Here's the answer.

    http://www.macromedia.com/cfusion/kn...fm?id=tn_14201


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •