Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 10 of 10
  1. #1
    New to the CF scene
    Join Date
    May 2011
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Flash objects not working in FF

    Hello, this is my first post and I'm a relative novice to web development, being self-taught, so have a lot to learn.

    I run a fan-site for Richard Ashcroft, and I have 3 swf objects on my homepage which worked perfectly fine until a couple of weeks ago, when they stopped showing correctly in FF and Safari, although they have no problem in IE.

    The code validates with W3C standards (except the code for the facebook button which I've given up trying to validate, but which works fine).

    If anyone can help with this problem I would be very grateful!

    Here is the code for one of my objects:

    Code:
    <object data="myjukebox2.swf" type="application/x-shockwave-flash" width="25" height="25">
    <param name="movie" value="myjukebox2.swf" />
    <param name="quality" value="high" />
    <param name="scale" value="noscale" />
    <param name="salign" value="lt" />
    <param name="bgcolor" value="#3A0112" />
    <param name="wmode" value="opaque" />
    </object>
    My website is http://richardashcroftonline.com

    Thanks in advance.
    Last edited by steal_away; 05-30-2011 at 09:39 PM. Reason: typo

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    That should work just fine although I recommend using http://code.google.com/p/swfobject/
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New to the CF scene
    Join Date
    May 2011
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks very much for your reply!
    I can only think a Firefox update must have caused the problem as initially everything worked fine.

    The same thing happened on a page of my other fansite:
    http://theverveonline.com/bittersweetstory.html
    There should be 4 swf objects which no longer show up in FF, although they still work in IE and Chrome.

    Thanks for the link - I'll give it a try...

  • #4
    New to the CF scene
    Join Date
    Jun 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    answer is not really required ....
    This is the plugin is really really helpful and useful for all webmasters, share your blog and share our links is worth a thousand grateful! Keep up the good work! WoW will always be part of the 10 best online game for me!

  • #5
    New to the CF scene
    Join Date
    May 2011
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by _Aerospace_Eng_ View Post
    That should work just fine although I recommend using http://code.google.com/p/swfobject/
    I was advised in that googlegroup that I didn't have correct markup to display the flash objects correctly ... and was directed to the tutorials...

    Thankfully I found out eventually that the problem was caused when I disabled hotlinking to images on the server - once I enabled this again everything was fine and no change of code was required!

  • #6
    New to the CF scene
    Join Date
    Sep 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have built a website that uses javascript to test whether a recent enough version of flash is installed in the browser and if it is writes the HTML to embed the flash banner. It is largely along the lines of what Macromedia recommends and uses both object and embed tags. It works fine in all IE browsers I have looked at and in most Firefox browsers, however it is not working on one Firefox browser I have looked at (version 1.5.0.4).

    some idea of the basis?


  • #7
    New Coder
    Join Date
    Oct 2011
    Posts
    11
    Thanks
    2
    Thanked 2 Times in 2 Posts
    I was having a similar issue with SWF files in CS3.

    What i did was to insert the SWF files a different way.

    The method that worked for me was "Insert/Media/Flash".

    Then select the SWF file.

    The "Insert/Media/Flash Video" worked on all the browsers I tried but only for FLV extensions.

    The "Insert/Media/Shockwave" method worked for me in Opera and Firefox, but not in IE, Crome or Safari browsers.

    ...

    I hope it works for you.

  • Users who have thanked shazib222 for this post:

    aishan111 (10-07-2011)

  • #8
    New to the CF scene
    Join Date
    Oct 2011
    Posts
    7
    Thanks
    2
    Thanked 1 Time in 1 Post
    Quote Originally Posted by shazib222 View Post
    I was having a similar issue with SWF files in CS3.

    What i did was to insert the SWF files a different way.

    The method that worked for me was "Insert/Media/Flash".

    Then select the SWF file.

    The "Insert/Media/Flash Video" worked on all the browsers I tried but only for FLV extensions.

    The "Insert/Media/Shockwave" method worked for me in Opera and Firefox, but not in IE, Crome or Safari browsers.

    ...

    I hope it works for you.
    Thanks it worked for me..

  • #9
    New Coder
    Join Date
    Nov 2011
    Posts
    16
    Thanks
    0
    Thanked 1 Time in 1 Post
    Just opened with my FF works like a charm

  • #10
    New Coder
    Join Date
    Nov 2011
    Posts
    16
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by steal_away View Post
    Thanks very much for your reply!
    I can only think a Firefox update must have caused the problem as initially everything worked fine.

    The same thing happened on a page of my other fansite:
    http://theverveonline.com/bittersweetstory.html
    There should be 4 swf objects which no longer show up in FF, although they still work in IE and Chrome.

    Thanks for the link - I'll give it a try...
    You can also try firefox plugin called "Flash Aid" it will fix any related flash problems. Will check different versions and if there is any conflicts will report it too.
    When talking about energy Cordyceps > Coffee


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •