Hello,

I am using the code below to embed a SWF movie into a div so that upon opening the page, the SWF movie will start. The movie (written in AS 3.0) is a fade in motion tween, causing an image fade in from a transparent background.

It worked fine in Firefox and Safari but the SWF will not start at all in IE.

Any comments would be appreciated. Thank you.

Here is the site address: www.designby-human.com/Lifecare

Here is the code I am using (this is embedded in a div tag):

<object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" width="177" height="127" id="FlashID" title="commercial">
<param name="movie" value="flash/commercial.swf" />
<param name="quality" value="high" />
<param name="wmode" value="window" />
<param name="loop" value="false"/>
<param name="swfversion" value="6.0.65.0" />
<!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you don’t want users to see the prompt. -->
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<param name="SCALE" value="exactfit" />
<!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="flash/commercial.swf" width="177" height="127">
<!--<![endif]-->
<param name="quality" value="high" />
<param name="wmode" value="window" />
<param name="loop" value="false"/>
<param name="swfversion" value="6.0.65.0" />
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<param name="SCALE" value="exactfit" />
<!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
<div>
<h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" /></a></p>
</div>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object>
</div>