Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    Regular Coder
    Join Date
    Aug 2002
    Posts
    247
    Thanks
    0
    Thanked 0 Times in 0 Posts

    problem with flash menu and target

    Can someone out there help me with this?

    I have a framed page with three panes and the code for the frameset is this:

    <frameset framespacing="0" border="0" cols="150,*" frameborder="0">
    <frame name="left" scrolling="no" noresize target="rbottom" src="left_side.cfm">
    <frameset rows="20%,*">
    <frame name="rtop" target="_self" src="top-side.cfm" scrolling="no">
    <frame name="rbottom" src="bottom-side.cfm" scrolling="auto">
    </frameset>


    I have a flash menu that I created that sits in the left pane or "left-side.cfm". In the code of this page is a Javascript function that looks like this:

    <script>
    function getPage(url) {
    parent.rbottom.location.href="audio.cfm" ;
    }
    </script>


    Now I have a page that I want to appear in the bottom frame or "bottom-side.cfm" called audio.cfm

    In the Flash menu there are 6 buttons and in the Object Properties box I have the getURL at JavaScript:getPage('covers.cfm','rbottom')

    Now if you go to this link:
    http://207.176.137.165/index3.cfm

    you will see the menu on the left. If you click the "live audio" button, the page that I want to appear does in the bottom pane. However, if you click any of the other buttons, the same page appears in that frame. That shouldn't happen because all the other buttons have links to different pages.

    So I have two questions:

    1) How do I get the proper linked pages to appear in the bottom frame?

    2) Notice when you load my page for the first time how the progression bar in the browser moves very slow and doesn't finsih. Why woudl that happen?

    Any help would be appreciated.

    Gary

  • #2
    Regular Coder
    Join Date
    Jul 2002
    Location
    This little Earth.
    Posts
    383
    Thanks
    0
    Thanked 0 Times in 0 Posts
    i'm not exactly sure i understand. do u mean that if u click on, say 'live video', or 'cover' or anything else, u still get 'live audio'? well it isn't happening with me. apparently the different links are working alright.
    and i don't get any progress bar either.
    'If you don't stand for something, you'll fall for anything.'


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •