Hi,
I am tiring to render a report from a ssrs web service via the ReportExecutionService. Sofar i maneged to import the WSDL but I cant seem to render reports. this is my code so far

[CODE]
<?xml version="1.0" encoding="utf-8"?>
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" layout="absolute">
<mx:Script>
<![CDATA[
import com.MyServer.ParameterValue;
import com.MyServer.ArrayOfParameterValue;
import com.MyServer.ExecutionHeader0;
import com.MyServer.ExecutionInfo;
import com.MyServer.ExecutionHeader;

import mx.controls.Alert;
import mx.rpc.soap.WebService;
import mx.rpc.events.ResultEvent;
import mx.rpc.events.FaultEvent;
import com.MyServer.ReportExecutionService;
import com.MyServer.RenderResultEvent;
import com.MyServer.DataSourceCredentials;
import com.MyServer.LoadReportDefinitionResultEvent;
import com.MyServer.ArrayOfParameterValue;
import com.MyServer.ExtensionTypeEnum;

private var reportPath:String = "/CCG Methodologies/rcr/CPT 7.0 Indicators";
private var format:String = "MHTML";
private var historyID:String = null;
private var myparameters:ArrayOfParameterValue = null
private var devInfo:String = null;
private var extension:String=null;
private var result:ByteArray;

private var rc:ReportExecutionService = new ReportExecutionService();
private var execHeader:ExecutionHeader = new ExecutionHeader();
private var execInfo:ExecutionInfo = new ExecutionInfo();

private var ans:Object;


private function load():void{

rc.addloadReportEventListener(myloadHandler);
rc.loadReport_header =execHeader;
rc.loadReport("/CCG Methodologies/rcr/CPT 7.0 Indicators", historyID);
}
private function myloadHandler(event:LoadReportDefinitionResultEvent):void{
myText.text = event.result.toString();
}

}

]]>
</mx:Script>

<mx:Button x="216" y="390" label="push me" id="btn" click="load();"/>
<mx:TextArea x="33" y="20" width="424" height="350" id="myText"/>

</mx:Application>

every time i reach the line:
[ICODE] c.loadReport("/reports/report", historyID);

my code crashes with the error :
"ReferenceError: Error #1069: Property trustedUserHeader194 not found on com.Myserver.TrustedUserHeader and there is no default value."

ideas anyone??

ps: if you have code sampels i can learn from, it wold be great.