I developed Windows forms desktop app in VS2005 and created deployment package (with VS2005 as well). Obviously when someone with the older system tries to install it, the program asks to download .NET 2.0 Framework. That scares many people. How can I add an automatic Framework intsllation if needed?

Also, when the deployment app asks to download 2.0 Framework, it shows (by Norton) as unsecure download. Any ideas why?