Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    Regular Coder
    Join Date
    Dec 2005
    Posts
    346
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Zone Alarm problems

    I have Zone Alarm Pro 6 running on my pc. I am almost sure Zone Alarm is causing my problems. I am designing a site with user login. I notice that I can't login & all my code is correct. I try it from another computer I can get get it. This other computer isn't running zone alarm.

    On my pc when I can't login, I immediately shutdown zone alarm & I can login. I restart zone alarm & I can login & logout & then log back in. I can login as many times as I want during that browser session. If I was to close all my browsers & try to login I can't. If I shutdown zone alarm then I can login.

    By not being able to login I mean by site can't read my $_SESSION's. I don't think they are getting set.

    Thanks!

  • #2
    Supreme Overlord Spookster's Avatar
    Join Date
    May 2002
    Location
    Marion, IA USA
    Posts
    6,278
    Thanks
    4
    Thanked 83 Times in 82 Posts
    Zone alarm has options to block cookies. Those sessions use cookies. So I would look around the disabling of cookies options and configure them as needed.
    Spookster
    CodingForums Supreme Overlord
    All Hail Spookster

  • #3
    Regular Coder
    Join Date
    Dec 2005
    Posts
    346
    Thanks
    1
    Thanked 0 Times in 0 Posts
    For this domain this is the current settings. I am in the Privacy section & on the Site List tab.

    Mobile code is allow
    Session cookies is allow
    Persistent cookies is allow
    3rd Party cookies is block

  • #4
    Regular Coder
    Join Date
    Dec 2005
    Posts
    346
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Does any body have any idea's on how to fix this problem?

  • #5
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    3rd party cookies should probably be allowed. Click on Privacy, click Add, add the site url, then right click on the red X's for that site and change to allow. I think the private header is the one that needs to be allowed.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #6
    Master Coder felgall's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Posts
    6,641
    Thanks
    0
    Thanked 649 Times in 639 Posts
    You need to allow private headers for sites that rely on document.referrer to work. Disabling third party cookies has never stopped me from being able to login to any site with zonealarm enabled.
    Stephen
    Learn Modern JavaScript - http://javascriptexample.net/
    Helping others to solve their computer problem at http://www.felgall.com/

    Don't forget to start your JavaScript code with "use strict"; which makes it easier to find errors in your code.

  • #7
    Regular Coder ArcticFox's Avatar
    Join Date
    Jan 2004
    Location
    Vostok Station, AQ
    Posts
    602
    Thanks
    35
    Thanked 3 Times in 3 Posts
    ZAPro gives me issues sometimes as well, like refusing to load pages or hold any types of coolkies (chocolate, mint, etc.).

    I just shut ZAPro down and restart it. This usually happens if the computer goes into hybernation or sleep mode... when it wakes up again, ZA gets cranky.
    <div> - putting your mind in a box since 1997


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •