Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    Regular Coder tylerjca's Avatar
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    162
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Apple iBook G4 Internet slowness

    Hello all,

    I received an old iBook G4, 1.33Ghz PowerPC, 768MB, 40GB (replaced original 60GB HDD because it was damaged). I installed Mac OS X 10.4.11 (Tiger) and also 10.5.8 (Leopard) each at different times. Currently it is running 10.5.8. It seems everything is running great, but I'm a Mac Noob so bare with me!

    The problem:
    Using Safari, when I try to check my Hotmail, or visit web sites with large CSS pages or basically anything that isn't really a small web page it takes a really long time (about 5 minutes) to load, and sometimes when it finally does, the style sheet doesn't load at all so the site becomes completely impossible to navigate. I've tried the same page(s) on my PC (Windows 7) and they load perfectly and within a couple seconds or less.

    The Network Environment:
    I have DSL at 6Mbps (slow, I know) with a Belkin [F6D4230-4 v1000] wireless router connected to the D-Link DSL2320B Modem. Most of my PCs are connected via WiFi as well as the iBook. I have tried it on LAN as well, but same problem exists.

    The Question:
    Is there anything I can do to fix this problem, or am I stuck selling the damn thing on eBay? It's basically worthless to me if I can't use the Internet reliably.

    Thanks to anyone with input.

    Oh and an additional detail, I know the network works well because I transferred an entire Mac OS X installation image (6GB+ in size) over the LAN and it transferred just fine in about 30 Minutes.

  • #2
    Supreme Overlord Spookster's Avatar
    Join Date
    May 2002
    Location
    Marion, IA USA
    Posts
    6,278
    Thanks
    4
    Thanked 83 Times in 82 Posts
    Have you tried other web browsers besides Safari?
    Spookster
    CodingForums Supreme Overlord
    All Hail Spookster

  • #3
    Regular Coder tylerjca's Avatar
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    162
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Yes actually. I've tried Firefox, which at first seemed to work well, but instead it does the same thing. After logging into Hotmail, it looks like it's loading for about 1 minute and then it says "The connection was reset." It does this to a few other sites as well, but google and CodingForums work well in both Safari and Firefox. I can only get version 3.6.25 for firefox..

  • #4
    Supreme Overlord Spookster's Avatar
    Join Date
    May 2002
    Location
    Marion, IA USA
    Posts
    6,278
    Thanks
    4
    Thanked 83 Times in 82 Posts
    Odd. Does your Mac use an internal wireless card or a plugin wireless adapter? If it's a plugin adapater you might try another one if you have one available to see if it's the adapter causing the issues. Also I would try connecting your Mac directly to the routerh via an ethernet cable and see if the problem persists. That would help to narrow down if the problem is with the wireless connection.
    Spookster
    CodingForums Supreme Overlord
    All Hail Spookster

  • #5
    Regular Coder tylerjca's Avatar
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    162
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Tried that earlier, as stated in my initial post, as well I'm trying it now.
    Firefox still gives the same "Connection was reset" and Safari says "Safari can’t open the page “http://mail.live.com/?rru=inbox” because the server unexpectedly dropped the connection. This sometimes occurs when the server is busy. Wait for a few minutes, and then try again."

    The WLAN card is removeable from underneath the keyboard, however I do not have another one to replace it let alone any that are Mac compatible. I have some USB WiFi adapters but PC only.

    I have a feeling this won't be fixable. .. Um anyone want to buy an iBook? haha J/K I'll keep trying but I think I may only keep it for learning more about the mac system.

  • #6
    Supreme Overlord Spookster's Avatar
    Join Date
    May 2002
    Location
    Marion, IA USA
    Posts
    6,278
    Thanks
    4
    Thanked 83 Times in 82 Posts
    Since it is occuring with both wired and wireless connections then it must be something with the O/S or drivers. I'm not a Mac person so I wouldn't be any further help there. Not sure why anybody would want to pay so much extra money for a Mac when a PC or laptop running Linux or worse yet MS Windows works just as well.
    Spookster
    CodingForums Supreme Overlord
    All Hail Spookster

  • #7
    Regular Coder tylerjca's Avatar
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    162
    Thanks
    1
    Thanked 0 Times in 0 Posts
    You might be right about the OS or Drivers. But I've got a version of mac installed onto my HP Pavilion DV5 and everything runs great except for the video and the same internet problem exists. Most web pages work great but Hotmail just refuses to load at all.

    Ah well... maybe it's a problem with the router? I have no idea but either way, at least the iBook didn't cost me anything, I got it as a gift.

    Thanks Spookster for your input.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •