Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Jan 2005
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    ASP sending mail problems... =/

    Hey fellows, I'm an ASP newbie,
    The following code WORKS GREAT on my computer, localhost-wize. When I upload it to my internet-host area (a domain.co.il perchuse) there's some error:

    CDO.Message.1 error '80040220'

    The "SendUsing" configuration value is invalid.

    /sendMail.asp, line 19




    The code:

    <html dir="rtl">

    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1255">
    <title>contact</title>

    <%
    sub sendMail()

    subject=Request.Form("messageTitle")
    from=Request.Form("replyMail")
    message=Request.Form("theMessage")

    Set myMail=CreateObject("CDO.Message")
    myMail.Subject="Message from my website: " & subject
    myMail.From=from
    myMail.To="freziy@zahav.net.il"
    myMail.TextBody=message
    myMail.Send


    end sub
    %>

    </head>

    <body bgcolor="#2E2E2E" topmargin="12" leftmargin="0" rightmargin="0" bottommargin="0" marginwidth="0" marginheight="0">
    <% call sendMail() %>
    <table border="0" width="600" cellspacing="0" cellpadding="0" height="400" id="table1">
    <tr height="30">
    <td background="signupperbg.JPG"><span lang="he"><u>
    <font size="5" color="#FBC81F"><b>צור קשר</b></font></u></span></td>
    </tr>
    <tr>
    <td valign="center" background="signupbg.JPG" align="center">
    <font face="Verdana" color="white"><span lang="he">
    <b>
    Message sent. Thanks.
    </b>
    </td>
    </tr>
    </table>

    </body>

    </html>


    I'de appriciate any help, thanks

  • #2
    New to the CF scene
    Join Date
    Jan 2005
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    oh no :-(

    I was sure to get a reply pretty soon, please, fellows...? =/
    It's important for me, no one knows what's the problem... ? =///

  • #3
    New to the CF scene
    Join Date
    Dec 2004
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Not much help but...

    I'm kinda new to this myself, but from my limited knowledge I wonder about a couple things. Would you get any different results if you had-

    Set myMail=Server.CreateObject("CDONTS.NEWMAIL")

    instead of

    Set myMail=CreateObject("CDO.Message")

    ?

    If that's no help, try this link.
    http://www.experts-exchange.com/Web/..._20783503.html

  • #4
    New to the CF scene
    Join Date
    Jan 2005
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wohoo, Success !!!

    Dear Burnout,
    did try that and had the same results.

    Out of upsetness I've Emailed my hosting service providor.
    Turned out to be a wize decision: they had me informed I can't write CreateObject("CDO.Message")
    since CDO is not installed on my server.

    That's why the code run well on my computer - CDO objects can be created on my localhost, unlike the server I'm hosting on.

    Well, they use the Persists AspEmail availible at www.AspEmail.com .
    All I changed in my code is the CreateObject line to be: CreateObject("Persits.MailSender") , that's how Persists AspEmail handles the creating of the mail object. The other mail object handling is pretty much the same as CDO's...


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •