Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    New Coder
    Join Date
    Jun 2002
    Location
    Delhi, India
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Hover Button's is not working???

    Hi! Friends,
    I tried calling an ASP page on the click of the Hover Button using Frontpage 2000. I have tried using the URL property of it, using functions in javascript and then calling it on the click method of the Button, but in vain. Am currently working with the Submit button only, which is working fine.
    Could any one of you kindly help me out with the same at the earliest.
    Thanks and have fun coding.
    -Kumar Navin.

    My code was:-


    <script language="javascript">
    function calling()
    {
    document.form.action="http://localhost/jewel/account.asp"
    }
    </script>
    <%
    ----
    ----


    <applet code="fphover.class" codebase="./" width="120" height="24">
    <param name="color" value="#000080">
    <param name="hovercolor" value="#0000FF">
    <param name="textcolor" value="#FFFFFF">
    <param name="text" value="Submit">
    <param name="effect" value="glow">
    <param name="url" value=calling()>
    </applet>

    ----
    ----
    %>
    Last edited by krnaveen; 06-20-2002 at 02:13 PM.

  • #2
    Regular Coder
    Join Date
    Jun 2002
    Location
    Cincinnati, OH
    Posts
    545
    Thanks
    0
    Thanked 0 Times in 0 Posts
    could you post some code?

  • #3
    Regular Coder
    Join Date
    Jun 2002
    Posts
    344
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Hover Button's is not working???

    Instead of using a fuction to enter a known value, why not just use the value???

    <%
    ----
    ----


    <applet code="fphover.class" codebase="./" width="120" height="24">
    <param name="color" value="#000080">
    <param name="hovercolor" value="#0000FF">
    <param name="textcolor" value="#FFFFFF">
    <param name="text" value="Submit">
    <param name="effect" value="glow">
    <param name="url" value="http://localhost/jewel/account.asp">
    </applet>

    ----
    ----
    %>

    ~Quack

  • #4
    New Coder
    Join Date
    Jun 2002
    Location
    Delhi, India
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Re: Hover Button's is not working???

    Originally posted by QuackHead
    Instead of using a fuction to enter a known value, why not just use the value???

    <%
    ----
    ----


    <applet code="fphover.class" codebase="./" width="120" height="24">
    <param name="color" value="#000080">
    <param name="hovercolor" value="#0000FF">
    <param name="textcolor" value="#FFFFFF">
    <param name="text" value="Submit">
    <param name="effect" value="glow">
    <param name="url" value="http://localhost/jewel/account.asp">
    </applet>

    ----
    ----
    %>

    ~Quack

    Dear QuackHead,
    Thanks for ur reply. But have tried that also, it isn't working. After this only I shifted to the function method. If u could try out and check where my fault lies. Thanks for your co-operation.
    -Navin.

  • #5
    Regular Coder
    Join Date
    Jun 2002
    Posts
    344
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Where did you get the applet from? (I don't use java applets at all - so I'm not familiar with this one)

    Wherever you got the applet, say from a download site, there should be detailed instructions on how to use it's parameters.

    There's really not much I can help you with, so hopefully the site where you got the applet from will have some troubleshooting FAQs

    ~Quack

  • #6
    New Coder
    Join Date
    Jun 2002
    Location
    Delhi, India
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hover Button is not working???

    Originally posted by QuackHead
    Where did you get the applet from? (I don't use java applets at all - so I'm not familiar with this one)

    Wherever you got the applet, say from a download site, there should be detailed instructions on how to use it's parameters.

    There's really not much I can help you with, so hopefully the site where you got the applet from will have some troubleshooting FAQs

    ~Quack

    Dear QuackHead,
    Am using Frontpage 2000. There in the Insert menu, followed by Component submenu, you have the option of inserting Hover Button. I got it from there. The Applet code is generated automatically. Thanks again.
    -Navin.

  • #7
    Rockstar Coder
    Join Date
    Jun 2002
    Location
    USA
    Posts
    9,074
    Thanks
    1
    Thanked 328 Times in 324 Posts

    Re: Hover Button's is not working???

    Originally posted by krnaveen
    <applet code="fphover.class" codebase="./" width="120" height="24">
    <param name="color" value="#000080">
    <param name="hovercolor" value="#0000FF">
    <param name="textcolor" value="#FFFFFF">
    <param name="text" value="Submit">
    <param name="effect" value="glow">
    <param name="url" value="calling()">
    </applet>

    ----
    ----
    Did you try that? Dunno if that will help. You try looking through the FrontPage help?

    Considering that it is from MS and it was packaged with FP, it most likely wasn't designed with that functionality in mind.
    OracleGuy


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •