Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Mar 2013
    Posts
    13
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Getting the environment details in ASP application.

    Hi,

    I am having in my machine already implemeted ASP application. In that i want to change the database details in global.asa file.

    In that for getting database instances the below code used.

    'Get the Oracle DB Instances
    '---------------------------
    Set Shell = Server.CreateObject("Wscript.Shell")
    Set SysEnv = Shell.Environment("SYSTEM")
    QMDB = SysEnv("QMDB")
    OADB = SysEnv("OADB")
    OSDB = SysEnv("OSDB")
    QSDB = SysEnv("QSDB")
    WBDB = SysEnv("WBDB")

    In the above code there are getting database detais from which place i am not able to understand can you please help me any one on this.

    Thanks,
    Ashok

  • #2
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    25,550
    Thanks
    78
    Thanked 4,382 Times in 4,347 Posts
    Those have anything to do with Global.ASA.

    Here's what Global.ASA is used for:
    http://www.w3schools.com/asp/asp_globalasa.asp

    Environment variables are typically set from the Control Panel, starting with the "System" icon. They are the basic settings that control where things are found on your computer, etc. Use "HELP" on your machine and search for "Environment Variables" and you can find all of them.
    An optimist sees the glass as half full.
    A pessimist sees the glass as half empty.
    A realist drinks it no matter how much there is.

  • Users who have thanked Old Pedant for this post:

    ashok-n (07-06-2013)

  • #3
    New Coder
    Join Date
    Mar 2013
    Posts
    13
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi Pedant,

    Yes i got it.

    It's in my computer properties -> under advanced Tab->Environment vaiables.

    Under that i changed it's working fine.

    Thank You very much for providing the solution to me.

    Thanks,
    Ashok


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •