...

View Full Version : Table display issue in Netscape 7.1



jacob999
09-28-2006, 11:27 AM
<table width="100%" id="infoPage" cellspacing="0" cellpadding="0">
//has a progress bar image
</table>

<table width="100%" id="realPage">
<tr>
<td><jsp:include page="/submitHandler.do" flush="true">
<jsp:param name="buttonClicked" value="<%=submitBtn%>" />
</jsp:include></td>
</tr>
</table>


On load of the above jsp, i am calling the following js function -


function initWait(){

if(document.getElementById){
document.getElementById('infoPage').style.visibility = 'hidden';
document.getElementById('realPage').style.visibility = 'visible';
}

As you can see, i want to display the progress bar as long as the included jsp (in the second table tag)is not completely displayed.
i also have the following <style> tag within the <head> tag of my jsp -


<style>
#infoPage {
position: absolute;
}

#realPage {
position: absolute;
visibility: hidden;
}
</style>

for all browsers, this code works fine i.e. the progress bar is displayed for some time and then the included jsp is displayed, but in case of NS 7.1, it is not working properly. Instead of displaying the progress bar image, it displays a blank page for some time, then just before the included jsp is about to be displayed, the progress bar is displayed for a split second.

Also this doesnt happen all the time. Sometimes it works as intended.
Can anyone help me out with this?

ronaldb66
09-28-2006, 01:14 PM
I don't know if your JavaScript function is internal or external, but it might have to do with the way, or order, NS7.1 loads the various components.
You could try to place the JS function internally in the page as well to make sure it is available once the page has loaded. The style rules are internal already, so they should be applied no matter what.

jacob999
09-29-2006, 08:35 AM
I don't know if your JavaScript function is internal or external, but it might have to do with the way, or order, NS7.1 loads the various components.
You could try to place the JS function internally in the page as well to make sure it is available once the page has loaded. The style rules are internal already, so they should be applied no matter what.

Thanks Ronald for your reply.

Yes, i was initially using an external function (i had it in a .js file). i tried adding this function internally in the jsp as well but still got the same issue.
This functinality is working properly for NS 7.2.

regards,
Jacob



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum