...

View Full Version : Navigation DIV not showing in IE



ColdFire
09-25-2006, 09:23 AM
Hey all,

I have a simple site that i have made for a friend of mine, i am still learning and converting to making sites in xhtml and css so it probably isnt the best coding in the world but i am getting there.

Anyway, if you goto http://www.gemalos-branston.co.uk in firefox you can see the page and also see the black navigation div on the left side of the page, if you goto the very same page in IE the div flashes up on load and then completely dissapears.

I have tried moving the html about and playing with the CSS but i have no idea why this is happening, the CSS is in the page for ease of viewing so if anyone has any ideas then it would be grately appreciated.

Thanx for reading.

Edit: Is there anyway i can fix the mispelling in the title?

ronaldb66
09-25-2006, 10:00 AM
The answer: absolute positioning. Try leaving the z-index off to begin with, but you'll probably be better of anyway by not using absolute positioning at all, but instead floating it left like you floated the main content right.

ColdFire
09-25-2006, 10:25 AM
Thanx for the reply,

I actually put the z-index as a complete guess at trying to get it to work, it wasnt there originally.

I have changed the code and floated it left, you will now see that it pushes the main content div down, they dont want to align next to each other.

It seems even making the width smaller doesnt help, another crazy thing is that there is a alrge amount of padding on the inside of the navigation box, i have worked out that it is something to do with the UL but not sure what.

I think i originally developed it using float left but changed to absolute because of this very problem.

How come IE has a problem anyway, is it hiding it under another div?



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum