...

View Full Version : Form Submission Problem



Uzair
09-20-2006, 12:00 PM
When I submit my form it shows...
THE PAGE CANNOT BE FOUND !
While the result page is there in the proper directory & everything is fine.
here is the code...


<form action="pwd_thanks.htm" method="post" name="forgotpwd" style="display:inline;" onSubmit="MM_validateForm('ID','','R','Email','','RisEmail');return document.MM_returnValue">
<table width="100%" border="0" cellpadding="0" cellspacing="0">
<!--DWLayoutTable-->
<tr>
<td height="97" colspan="4" class="tdpad"> If you've forgotten the password to your account, please confirm your identity below and enter your User ID &amp; Email Address. We will provide you with a new password.<br>
<br>
<span class="style2">All fields are required!</span> </td>
</tr>
<tr>
<td width="202" height="28" valign="top"><!--DWLayoutEmptyCell-->&nbsp;</td>
<td width="80" valign="top" class="tdpad"><strong>User ID: </strong></td>
<td colspan="2" valign="top" class="tdpad"><input name="ID" type="text" id="ID" size="17" maxlength="14"></td>
</tr>
<tr>
<td height="28" valign="top"><!--DWLayoutEmptyCell-->&nbsp;</td>
<td valign="top" class="tdpad"><strong>Email: </strong></td>
<td colspan="2" valign="top" class="tdpad"><input name="Email" type="text" id="Email" size="17" maxlength="14"> </td>
</tr>
<tr>
<td height="30" colspan="2" valign="top" class="tdpad"><!--DWLayoutEmptyCell-->&nbsp;</td>
<td colspan="2" valign="top" class="tdpad"><input name="pwdSubmit" type="submit" id="pwdSubmit" value="Get Password"></td>
</tr>
<tr>
<td height="19" colspan="4" valign="top"><hr size="1" noshade class="lftmenucell"></td>
</tr>
<tr>
<td height="32" colspan="3" valign="top" class="tdpad"><span class="style1">&nbsp;&nbsp;&nbsp;<strong></strong>Don't have a MeriSite ID?</span><br>
&nbsp;&nbsp;&nbsp;<strong></strong>Signing up is very much easy...</td>
<td width="92" align="right" valign="top" class="tdpad"><a href="signup.htm" class="topuser">Sign Up Now!</a> </td>
</tr>
<tr>
<td height="47"></td>
<td></td>
<td width="238"></td>
<td></td>
</tr>
</table></form>

Desdinova
09-20-2006, 12:31 PM
it's very very likely that the path isn't correct. check your capitals, your extension (.htm, not .html)

Uzair
09-20-2006, 01:03 PM
No its not a matter of capitals & extensions.
I'm chekin ma form on IIS.
I think its becoz of IIS configuration. IIS stops form executing the results. But I'm not sure about this.

Somebody please help me fixing this problem.

Desdinova
09-20-2006, 01:19 PM
what's IIS?

and what's the URL you see in the addressbar on the 404-page?

Uzair
09-20-2006, 01:24 PM
The same URL which I gave in [form action="xxx" ]
After getting the Msg "THE PAGE CANNOT B DISPLAYED", when I hit the browser's GO button twise or thrise, then the the result page loads. Don't know wot the hell is going on with my form...



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum