View Full Version : Sitemap not validating!

08-14-2006, 11:07 AM
Hi all,

I am using the sitemap validator here: http://www.smart-it-consulting.com/internet/google/submit-validate-sitemap/index.htm (which, in its turn, implements a widely used validator)

to validate my test sitemap here: http://www.mlse.co.uk/sitemap.xml


It isn't validating! (the error report is that the schema is not recognised).

Now for the weird bit: I found this sitemap (advertised on another sitemap validation site as being a good example of a valid sitemap): http://www.hvac-direct.com/sitemap.xml

Note that this second sitemap validates perfectly.

Note also that the headers in my sitemap and their sitemap are absolutely identical (other than the link to their stylesheet in their sitemap).

Also, my headers are identical to the ones that Google states are required for validation here: https://www.google.com/webmasters/sitemaps/docs/en/protocol.html#sitemapValidation

I am a little perplexed ....

Any ideas gratefully received!



08-14-2006, 05:21 PM
Have you actually tried it on google? I can't see a problem with your map.

I've been using mine for some time on google :
it uses a simpler urlset

you may also find googles information informative. copy and past from here and then you can't go wrong.


The bottom line is does it work on google, 3rd party validators are somewhat irrelevant. It's not like an rss feed that needs to be compliant accross the board.

08-15-2006, 01:45 PM

Yep, I went ahead and submitted it to Google anyway, and Google was quite happy with it!