...

View Full Version : Plugin problems



v777tony
06-24-2006, 07:39 AM
Does anyone know the plugin page or codebase for windows media player (application/x-mplayer2)?

_Aerospace_Eng_
06-24-2006, 07:54 AM
Can you explain more in detail what your problem is? What are you trying to do?

v777tony
06-25-2006, 08:16 AM
Basically, I'm trying to get this to play in the background.
(I don't use <bgsound> because it takes longer to load)


<object type="application/x-mplayer2" classid="CLSID:22D6f312-B0F6-11D0-94AB-0080C74C7E95" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701" style="display:none;" width="0" height="0">
<param name="filename" value="sound/Demon Hunter - Not Ready To Die.mp3">
<embed src="sound/Demon Hunter - Not Ready To Die.mp3" type="application/x-mplayer2" pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/Products/MediaPlayer/" hidden="true" width="0" height="0">
</object>


As you can see I have the codebase and stuff. But it doesn't want to work in firefox. I've though about switching the type to audio/mpeg, but I don't know it's codebase (pluginspage) either.

I also have an m3u file on a seperate page (only not hidden) that has the same effect. I have it's type set to audio/mpegurl. I don't even have a codebase (pluginspage) for it though.
Same thing with wav files. I have them set to application/x-mplayer2 but I don't know if they should be audio/x-wav or not.

It seems to work fine in other browsers. Though I haven't tested this in opera.
My flash objects seem to work in every browser. It's just all my mp3, m3u, and wav files.

_Aerospace_Eng_
06-25-2006, 08:24 AM
<bgsound> doesn't even work in Firefox. audio/mpeg really has no plugins page or codebase, its up to the browser which player it will use. Try this

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<title></title>
<style type="text/css">
html, body {
margin:0;
padding:0;
}
#music {
position:absolute;
left:0;
top:0;
height:1px;
width:1px;
}
</style>
</head>
<body>
<div id="music">
<object type="application/x-mplayer2" width="0" height="0" data="sound/Demon%20Hunter%20-%20Not%20Ready%20To%20Die.mp3">
<param name="src" value="sound/Demon%20Hunter%20-%20Not%20Ready%20To%20Die.mp3">
<param name="filename" value="sound/Demon%20Hunter%20-%20Not%20Ready%20To%20Die.mp3">
<param name="type" value="application/x-mplayer2">
<param name="autostart" value="true">
Your system does cannot find the windows media player that was specified.
</object>
</div>
</body>
</html>
Pay attention to the styles used. They are important to keeping the player 'hidden'. On a server this should work, locally it might not.

v777tony
06-25-2006, 05:10 PM
Well, I tried it. Didn't work in FF. But, it still worked in IE.
(Note: had to take out '%20' symbols for it to work locally)
Is it possible I could nest another object in the first object? Maybe I could use object type that's supported in FF.

You should also know it didn't display the message:
"Your system does cannot find the windows media player that was specified."

_Aerospace_Eng_
06-25-2006, 06:07 PM
When I tried it worked both in IE and FF. Can you post a link to your site?

v777tony
06-25-2006, 09:35 PM
When I tried it worked both in IE and FF. Can you post a link to your site?
I don't have it hosted yet.:( Do I need to include the codebase? Does it need to be uploaded to a server to work? I made sure everything was correct, the doctype, styling, div, ect. but it doesn't wanna play in FF.

_Aerospace_Eng_
06-26-2006, 02:20 AM
I put mine on a server and it worked fine. What is stopping you from uploading your site? There are free hosts you know.

v777tony
06-26-2006, 05:08 AM
I put mine on a server and it worked fine. What is stopping you from uploading your site? There are free hosts you know.
I could never find a good one. But I found one recently (it may only be temporary though), and for some reason it won't upload my main page. But it did all my other pages and you can access them here. http://three.fsphost.com/aashow. The object I showed you is in ak.htm.
Note: It may take a little while to download the first time. If you have DSL or better it should only take a sec or 2.

EDIT: I found a better host. My site is here http://aashow.phpnet.us/

_Aerospace_Eng_
06-26-2006, 06:31 AM
Try this

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Andrew Kelly</title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta http-equiv="Content-Script-Type" content="text/javascript">
<meta http-equiv="Content-Style-Type" content="text/css">
<meta http-equiv="Site-Enter" content="progid:DXImageTransform.Microsoft.gradientWipe(duration=2)">
<meta http-equiv="Page-Exit" content="progid:DXImageTransform.Microsoft.pixelate(duration=2)">
<link rel="stylesheet" type="text/css" href="css/vscroll.css">
<style type="text/css">
<!--
html, body {
background:#000 url('pic/ak.jpg') center no-repeat fixed;
margin:0;
padding:0;
color:#FFF;
scrollbar-face-color:#00F;
scrollbar-arrow-color:#F00;
scrollbar-3dlight-color:#FFF;
scrollbar-darkshadow-color:#000;
scrollbar-highlight-color:#FFF;
scrollbar-shadow-color:#000;
scrollbar-track-color:#008080;
font-family:BixAntiqueScriptHmkBold, Verdana, Arial, Helvetica, sans-serif;
height:100%;
}
a, a:link {
color:#008000;
background-color:inherit;
}
a:visited {
color:#F00;
background-color:inherit;
}
h2 {
text-align:center;
margin:0;
padding:15px 0 0 0;
}
#nav {
margin:0 0 0 10px;
padding:0;
width:134px;
height:110px;
list-style:none;
float:left;
display:inline;
}
#music {
position:absolute;
left:0;
top:0;
width:1px;
height:1px;
}
#ak-m {
float:right;
margin-top:-20px;
margin-right:10px;
display:inline;
}
-->
</style>
<script type="text/javascript" src="javascript/sound.js"></script>
<script type="text/javascript" src="javascript/decrypt.js"></script>
<script type="text/javascript" src="javascript/rollover.js"></script>
<script type="text/javascript">
window.onload = function()
{
window.moveTo(0,0);
window.resizeTo(screen.availWidth,screen.availHeight);
}
</script>
</head>
<body>
<h2>About Andrew Kelly</h2>
<ul id="nav">
<li><a href="index.htm" onmouseover="playSound('navsound0'); statusIn('Go Back Home If You Must');return true" onmouseout="statusOut();"><img src="pic/1d.bmp" class="rollover pic/1d_over.bmp" alt="Back Home" align="top" border="0" width="134" height="22"></a></li>
<li><a href="au.htm" onmouseover="playSound('navsound0'); statusIn('Who The Heck Are These People?');return true" onmouseout="statusOut();"><img src="pic/2d.bmp" class="rollover pic/2d_over.bmp" alt="Learn Our Ways" align="top" border="0" width="134" height="22"></a></li>
<li><a href="cu.htm" onmouseover="playSound('navsound0'); statusIn('Call, Email, Address, ect.');return true" onmouseout="statusOut();"><img src="pic/3d.bmp" class="rollover pic/3d_over.bmp" alt="How to contact A&amp;A" align="top" border="0" width="134" height="22"></a></li>
<li><a href="aw.htm" onmouseover="playSound('navsound0'); statusIn('About This Guy Named Andrew W.');return true" onmouseout="statusOut();"><img src="pic/4d.bmp" class="rollover pic/4d_over.bmp" alt="Learn about one of the hosts" align="top" border="0" width="134" height="22"></a></li>
<li><a href="ml.htm" onmouseover="playSound('navsound0'); statusIn('What Time Does That Song Play?');return true" onmouseout="statusOut();"><img src="pic/5d.bmp" class="rollover pic/5d_over.bmp" alt="View time listings for broadcasted music" align="top" border="0" width="134" height="22"></a></li>
</ul>
<object type="application/x-mplayer2" width="0" height="0" data="sound/menu1.wav" name="navsound0" id="navsound0">
<param name="url" value="sound/menu1.wav">
<param name="uiMode" value="full">
<param name="autoStart" value="false">
<param name="playCount" value="1">
<embed src="sound/menu1.wav" width="0" height="0" autostart="0" playcount="1" type="application/x-mplayer2" pluginspage="http://microsoft.com/windows/mediaplayer/en/download/" showcontrols="1" uimode="full"></embed>
</object>
<object type="application/x-shockwave-flash" data="flash/ak-m.swf" id="ak-m" name="ak-m" width="141" height="50">
<param name="movie" value="flash/ak-m.swf">
<param name="quality" value="high">
<param name="wmode" value="transparent">
<br>
<a href="ak-b.htm" target="_blank">Andrew's Bio</a><br>
<a href="ak-j.htm" target="_blank">Andrew's Journal</a><br>
<a href="ak-p.htm" target="_blank">Andrew's Photos</a><br>
<a href="ak-v.htm" target="_blank">Andrew's Videos</a>
</object>
<div id="music">
<object classid="CLSID:clsid:6BF52A52-394A-11D3-B153-00C04F79FAA6" width="0" height="0">
<param name="url" value="http://three.fsphost.com/aashow/sound/Demon%20Hunter%20-%20Not%20Ready%20To%20Die.mp3">
<param name="uiMode" value="full">
<param name="autoStart" value="true">
<param name="playCount" value="1">
<embed src="http://three.fsphost.com/aashow/sound/Demon%20Hunter%20-%20Not%20Ready%20To%20Die.mp3" width="0" height="0" autostart="1" playcount="1" type="application/x-mplayer2" pluginspage="http://microsoft.com/windows/mediaplayer/en/download/" showcontrols="1" uimode="full"></embed>
</object>
</div>
</body>
</html>

v777tony
06-26-2006, 08:56 AM
It works in FF!:D Yaaaaay! Only now, in doesn't work in IE.:eek: Plus in IE my rollover effect doesn't work.:(

_Aerospace_Eng_
06-26-2006, 09:00 AM
Move this

<script type="text/javascript" src="javascript/rollover.js"></script>
just before your </body> tag and update the page please. I tested this and it worked in IE and FF.

v777tony
06-27-2006, 06:31 AM
Thnx 4 stickin there and helpin me. My new site address is here http://aashow.phpnet.us/
Though I'm still confused about this plugins thing.

_Aerospace_Eng_
06-27-2006, 06:34 AM
Please pay attention to the code I gave you. Look it over and compare it to yours.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum