...

View Full Version : Problem with "enabling" $_SERVER['PATH_INFO']



mat106
05-07-2006, 02:56 AM
Hi all,

Can someone please tell me where exactly in httpd.conf i'm supposed to place AcceptPathInfo On for it to work? I've tried placing it within <Directory /> i.e.


<Directory />
Options FollowSymLinks
AllowOverride None
AcceptPathInfo On
</Directory>

I've tried placing it within the following:


<Directory "C:/Documents and Settings/.../My Documents/localhost">
...
AcceptPathInfo On
...
</Directory>
and i've tried placing it in the "root" of httpd.conf. However $path = $_SERVER['PATH_INFO']; generates the error Notice: Undefined index: PATH_INFO in C:\Documents and Settings\...\My Documents\localhost\path\filename.php on line 4

Any ideas? Thanks.

marek_mar
05-07-2006, 11:13 AM
you could try
$_ENV['PATH_INFO']; or
getenv('PATH_INFO'];

mat106
05-07-2006, 12:03 PM
I've tried both of those and they don't seem to work. Not surprisingly, i think, since neither, like $_SERVER['PATH_INFO'] appear in the Apache/PHP configuration details shown by echo phpinfo();.

Is it possibly a PHP configuration thing as opposed to an Apache issue.

NancyJ
05-07-2006, 01:49 PM
http://www.yhua.ac.uk/manual/mod/core.html

Philipp
05-07-2006, 04:29 PM
may a conflict with the savemode of php or apache.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum