...

View Full Version : SQL processing format



johnnybananas
05-03-2006, 01:54 AM
I am having problems with the sql database from a script I downloaded from this link

http://jonroig.com/freecode/openautoclassifieds/

From the phpMyAdmin console I scroll down to

Run SQL query/queries on database and then I cut-n-paste the code below and click "go". I get the following pop-up window...

Missing Value In The Form

Can anyone please offer some assistance?

---------- SQL Code ----------

CREATE TABLE agent_tbl_Files (id_files tinyint(3) unsigned NOT NULL auto_increment, bin_data longblob NOT NULL,description tinytext NOT NULL,filename varchar(50) NOT NULL,filesize varchar(50) NOT NULL,filetype varchar(50) NOT NULL,agentnum int(11) DEFAULT '0' NOT NULL,owner int(11) DEFAULT '0' NOT NULL,PRIMARY KEY (id_files));
CREATE TABLE agents (id int(11) NOT NULL auto_increment,agent varchar(30),agentpass varchar(10),agenturl varchar(70),agentemail varchar(70),notes text NOT NULL,agentphone varchar(30) NOT NULL,agentcell varchar(30) NOT NULL,agentfax varchar(30) NOT NULL,PRIMARY KEY (id));

CREATE TABLE tbl_Files (id_files tinyint(3) unsigned NOT NULL auto_increment,bin_data longblob NOT NULL,description tinytext NOT NULL,filename varchar(50) NOT NULL,filesize varchar(50) NOT NULL,filetype varchar(50) NOT NULL,owner varchar(30) NOT NULL,prop_num int(11) DEFAULT '0' NOT NULL,PRIMARY KEY (id_files));

CREATE TABLE vehicles (id int(11) NOT NULL auto_increment,title varchar(250),city varchar(50),state varchar(20),zip varchar(20),price int(11),fulldesc text NOT NULL,type varchar(20),featured char(1),dateposted date,agent varchar(30), notes mediumtext NOT NULL,owner int(11) DEFAULT '0' NOT NULL,model varchar(30) NOT NULL, make varchar(30) NOT NULL,year year(4) DEFAULT '0000' NOT NULL,drivetrain varchar(30) NOT NULL,transmission varchar(30) NOT NULL,body varchar(30) NOT NULL,doors int(11) DEFAULT '0' NOT NULL,features text NOT NULL,stereo varchar(30) NOT NULL,color varchar(30) NOT NULL,miles int(11) DEFAULT '0' NOT NULL,opt1 char(1) DEFAULT 'N' NOT NULL,opt2 char(1) DEFAULT 'N' NOT NULL,opt3 char(1) DEFAULT 'N' NOT NULL,opt4 char(1) DEFAULT 'N' NOT NULL,opt5 char(1) DEFAULT 'N' NOT NULL,opt6 char(1) DEFAULT 'N' NOT NULL,opt7 char(1) DEFAULT 'N' NOT NULL,opt8 char(1) DEFAULT 'N' NOT NULL,opt9 char(1) DEFAULT 'N' NOT NULL,opt10 char(1) DEFAULT 'N' NOT NULL,PRIMARY KEY (id));

guelphdad
05-03-2006, 03:05 AM
You have four table creation statements there. tell us which separate table statement is giving you the error. try one table at a time.

vinyl-junkie
05-03-2006, 03:48 AM
These SQL queries run just fine for me when I run them from phpMyAdmin. Are you sure you're not missing a step in whatever you're trying to do?

GJay
05-03-2006, 08:28 AM
That error message does strike me as being a phpmyadmin one, rather than anything to do with the SQL itself...



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum