...

View Full Version : Server object, ASP 0177 (0x800401F3) - just installed VS.NET



crmpicco
04-24-2006, 05:23 PM
THis is a code snippet from my Classic ASP File 'nf1_search_db.asp' :


set objdll = server.CreateObject("PiccoDb.SearchFares") <---- THIS LINE
set objxmlReply = server.CreateObject("Microsoft.freethreadedXMLDOM")
Set objxmlReply = objdll.PiccoSearchQuery(objxml)



I get this error on the line above, does anyone know why this would be the case?

Error:



Error Type:
Server object, ASP 0177 (0x800401F3)
Invalid class string
/v2/asp/net_includes/nf1_search_db.asp, line 207


I installed Visual Studio .NET this morning and now i get this after I registered (regsvr32) a new DLL.

Has installing VS.NET blocked calls to Server.CreateObject?

Thanks,
Picco
:eek:

crmpicco
04-27-2006, 11:13 AM
<%
response.write "TEST"
Set nl=Server.CreateObject("MSWC.NextLink")
%>


I have this file 'testSer.asp' inside my wwwroot - that is all thats in it. It gives me this error;



Error Type:
Server object, ASP 0177 (0x800401F3)
Invalid class string
/testSer.asp, line 5



I have uninstalled and then re-installed IIS from the support CD and unistalled .NET framework completely??

akgiddings
05-10-2006, 11:03 PM
I had a similiar problem after installing VS 2005, Except mine was with creating the Scripting.Dictionary object.

To Fix:
run RegEdit, Find the key

HKEY_CLASSES_ROOT\PiccoDb.SearchFares

From the Edit menu, select permissions...

Add in the Internet Guest Account user (machname\IUSR_machname)
Check on the "Allow" "Read" checkbox.


Good luck!

tunghnt
06-11-2007, 05:38 AM
I had a similiar problem after installing VS 2005, Except mine was with creating the Scripting.Dictionary object.

To Fix:
run RegEdit, Find the key

HKEY_CLASSES_ROOT\PiccoDb.SearchFares

From the Edit menu, select permissions...

Add in the Internet Guest Account user (machname\IUSR_machname)
Check on the "Allow" "Read" checkbox.


Good luck!


I had the same problem when creating FileSystemObject. It announced "invalid class string". I loss a lot of time finding out the way to solve. When reading this post, I see you suggest that Set Permission can solve so I try. But it didn't work when setting permission for Internet Guest Account Users. I try to set permission for HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Scripting.FileSystemObject with permission as same as it's neighbor's permission so it worked.
Thanks for your suggestion.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum