View Full Version : IE6.0, Ok. Moz 1.1, Ok. NS 6, slightly off!

10-18-2002, 05:00 PM
I think you will see it. Any clues? I struggled with this last night for quite some time and thought I was finished, only to test it with NS 6.2.3 (and Moz1.0) and find this disappointing mis-alignment. (the nav bar is off kilter)


You can run the W3C validator to view the CSS, or go here

Tried a few things this morning...no luck. Also, anyone who can test this page in IE 5.x I'd like to know the results.

10-18-2002, 05:27 PM
Hey beetle…

I tried IE5.1.5 on a Mac - crashed 3 times on the trot?????

Works fine in Moz 1.1 on the Mac but IE…

What happened is that it fully loaded for about 5 seconds and then wham… goodbye. :(
However it eemed (in those 5 seconds) to appear to look alright

10-18-2002, 05:44 PM
Ok, what you said about the Mac locking up got me thinking that it was my whitespace cleaner, which ended up not really being the problem, but it led me to the solution. Here's a copy of the page w/o the whitespace cleaner function. Let me know if it still crashes yer Mac.


10-18-2002, 06:10 PM
OK it works fine now on the ol' Mac and IE5.1.5

What is this 'whitespace cleaner function'?

And I've never seen this before…

<img src="http://www.w3.org/Icons/valid-xhtml10" border="0" alt="Valid XHTML 1.0" style="float:right; padding:0px 10px;" />

…is this 'strict XHTML' practice with img tags?


10-18-2002, 06:17 PM
Yes, with XHTML all tags that have no separate closing tag must be ended that way. Some others off the top of my head are

<meta />
<br />
<hr />
<link />
<area />
<input />

As far as the whitespace cleaner goes...read this (http://www.sitepointforums.com/showthread.php?s=&threadid=76795)

Alex (moderator here) also posted one (http://www.codingforums.com/showthread.php?s=&threadid=7028) which is slighty different from mine, but essentially the same thing.

I'll just have to throw in a little sniffing to make sure that it doesn't run on Macs.


Alex Vincent
10-19-2002, 03:04 AM
Netscape 6 is based on Mozilla 0.6, 6.1 on 0.9.2, and 6.2 on 0.9.4. Given these facts, you can be assured that Netscape 6 is not fully CSS-compliant.

Netscape 7 is based on Mozilla 1.0.1 (a significant difference) -- how does it look in that?

10-19-2002, 03:43 AM
Not sure about NS7, but I'll assume it's ok because it's picture perfect in Moz 1.0 and 1.1 :D