View Full Version : Weird IE Problem

11-30-2005, 11:09 PM
I've got a bit of a random bug in IE and I haven't a clue on what is happening or why, making it a rather annoying problem

I've got a tabbed menu at the top which allows me to change the page, however for some reason in IE it prints the last 3 characters of the last tab underneith the tabs as well as within the tabs. I can't give you a link to the site as it's not live and only on my test server. To check it isn't the server, I sent it to a mate who also checked it and he gets the same problem.

I've attached a screenshot of the problem and the source code for the page (using view>source). If anyone can shine any light on this issue, I'd be very grateful.

<div class="header">
<img src="../templates/admin/img/logo.gif" alt="PW*Websolutions Logo" class="header_left" />
<div class="header_right_top"><img src="../templates/admin/img/clubcms.gif" alt="PW*Club CMS" class="header"/></div>
<div class="header_right_menu"><ul><li class="active"><a href="index.php?sCat=settings">Settings</a></li><li><a href="index.php?sCat=cms">Website</a></li><li><a href="index.php?sCat=administration">Administration</a></li></ul></div>
<div class="bar">
<div class="bar_left"><a href="http://support.pw-websolutions.com" title="PW*Websolutions support"><img src="../templates/admin/img/help_icon.gif" alt="PW*Support Link" /></a></div>
<div class="bar_right"></div>

Many thanks in advance,

11-30-2005, 11:43 PM
Do you have any comments in your html? Start removing comments one by one until the problem goes away. I know it sounds far fetched but trust me IE is that kind of browser.

12-01-2005, 08:14 AM
Thanks for the reply, but there are no comments printed to the html. As this is a dynamic page, comments are stripped from the template files when they're printed, so that the user can see what things are meant to be when using the template files, with full explainations but the general public won't see them.

Any other thoughts?

12-01-2005, 08:19 AM
Can you give us a link to the generated html page?

12-01-2005, 08:21 AM
I can't give you a link to the page as it stands, as it requires user login, however, I'll take the source code and create a static page if that's any use?

12-01-2005, 08:22 AM
Yep that would work, create the static page give us a link. Something you could try doing on your own, its start taking out html until the problem goes away.

12-01-2005, 08:39 AM
Okay the link for the static page is this:

Link Removed

I'll start removing the html bit by bit later on, when I get back from work.

Thanks again,

12-01-2005, 08:42 AM
PIE describes the "Explorer 6 Duplicate Characters Bug (http://www.positioniseverything.net/explorer/dup-characters.html)"; this may help, however they do blame comments as the culprit (as _Aerospace_Eng_ already indicated).
If you're absolutely sure that there aren't any comments in between the floated elements you might have found a new bug! Jay!

You beat me to it; nope! No comments whatsoever! Not even whitespace, in fact.
This is realy, really weird.

12-01-2005, 08:46 AM
Wow!! I do hope not, as that means there's no solution to the problem already out there :D

I thought it may be the JS that I've got but even if I remove it, it still doesn't help. :(

12-01-2005, 08:53 AM
I guess this is just a case of the peekaboo bug. Add this to your CSS

.header_right_menu ul li {
This seems to fix it.

12-01-2005, 08:55 AM
Thanks a million!

The peekaboo bug? Hmm must make a note of that one and the solution.

Thanks again