View Full Version : Missing abs positioned div in IE

11-29-2005, 11:13 AM

Been trying to work out what's going on with a site I'm working on:

URL of the page is http://dev.tripsis.co.uk/.

In Firefox, the panel on the right displays no problem, but it's not displayed at all in IE (looking at both on PC/XP).

The panel is an absolutely positioned div. I've tried extending it to make sure it's not being hidden behind anything, but that's not worked. If I hide all the main content of the page (p and h2's) then it displays but that's not very handy.

Tried z-index and that didn't make any difference.

I thought that it might have been because the page 'holder' is position absolutely, but switching this off doesn't make any difference.

Any help would be very much appreciated.



11-29-2005, 11:29 AM
Might this be the culprit?

#pageholder {
z-index: 1000;
} I'm the first to admit I don't really "get" the whole "z-index" thing; that's why I usually leave 'em of entirely... :D

11-29-2005, 11:39 AM
I only added the z-index as an attempt to fix it, so this shouldn't be causing the problem (since it was broekn before I added it). I gave the panel a z-index of 2000 to try and get it to show but didn't have any luck.

(I don't really get the z-index either!)

11-29-2005, 11:45 AM
Took the z-index stuff back out, just to check, but didn't make any difference.

Just for clarification, all the positional stuff is inside dev.tripsis.co.uk/css/layout.css.

Panel is positioned with #portfoliothumbs {}.


11-30-2005, 03:41 AM
man this is weird. i saw this post this morning before work. I copied your files and started looking around and trying some stuff out. I came homke and it wasn't solved so back to work.

i started by checking the way you centered the page with neg. margins. Then I tried relative positoning and changing the absolute positioning margins to see i fI could at least get the side bar to show up any where on the page. then I looked through your other css files to see if there were any conflicts and then double checked your layout css and html layout for the same.

i then moved stuff around on the page and got it to appear if i place the sidebar above the last P in your content.

so I erased the last P after checking the css for it and the html for errors and the sidebar vanished again.

heres what I found.

erase the red line:

#footer {
width: 728px;
padding: 5px 16px;
float: left;

now look at it in IE.

you'll now need to give the fotter a height to make it look right.

11-30-2005, 11:22 AM
Wow, thanks so much for that!

Don't think I'd have ever tracked it down to the footer. :thumbsup: