...

View Full Version : problem with picture importing the white as well



radiohead
11-23-2005, 06:36 AM
as you can see in the pictures, when i put in the picture it puts in the white that is not meant to be there. this only happens in ie, but not in firefox. they are imported and pngs btw.

http://x12.putfile.com/11/32600342230-thumb.jpg (http://putfile.com/pic.php?pic=11/32600342230.jpg&s=x12)
http://x12.putfile.com/11/32600353660-thumb.jpg (http://putfile.com/pic.php?pic=11/32600353660.jpg&s=x12)

ronaldb66
11-23-2005, 08:05 AM
IE doesn't support png's full alpha channel; did you save that png with full 8 bit transparency? If so, IE will replace the transparent sections with some solid color.

radiohead
11-23-2005, 01:16 PM
IE doesn't support png's full alpha channel; did you save that png with full 8 bit transparency? If so, IE will replace the transparent sections with some solid color.

well i'd say that must be the case. i saved it as a png 32, seeing as if i save it as a jpeg it includes the white by default, not only in ie. what would i do to fix this?

people really need to ditch that piece of sh*t and use firefox.

ronaldb66
11-23-2005, 02:50 PM
IE does support single bit transparency on/off; you could save your image as such a png, or make a gif out of it.
I do recall there are methods for grafting png support onto IE, but I really can't tell how reliable those are. Google for "ie png support" or go directly to ALA's "Cross-Browser Variable Opacity with PNG: A Real Solution (http://www.alistapart.com/stories/pngopacity/)" to test the waters.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum