...

View Full Version : WinIE CSS Tabs won't work....



deadlandmine
08-25-2005, 04:17 AM
Hey, got this little site here and it works fine on everything except WinIE. The problem is that I have a subnav that doesn't show up. Absolutely no idea why. Any ideas? I got the CSS tabs idea from

kalsey.com/tools/csstabs/ (http://www.kalsey.com/tools/csstabs/)

My Site:
http://sedlackdesign.com/creative/work/

and some CSS:
http://sedlackdesign.com/styles/all.css

_Aerospace_Eng_
08-25-2005, 06:37 AM
It has to do with this part of your CSS

#menu #subnav-1,
#menu #subnav-2,
#menu #subnav-3,
#menu #subnav-4,
#menu #subnav-5,
#menu #subnav-6,
#menu #subnav-7 {
display: none;
left: -124px;
position: absolute;
top: 28px;
z-index: 2;
}

body.section-1 #menu ul#subnav-1,
body.section-2 #menu ul#subnav-2,
body.section-3 #menu ul#subnav-3,
body.section-4 #menu ul#subnav-4,
body.section-5 #menu ul#subnav-5,
body.section-6 #menu ul#subnav-6,
body.section-7 #menu ul#subnav-7 {
display: block !important;
left: -124px;
position: absolute;
top: 28px;
z-index: 2;
}
It appears that your lists are nested improperly not quite sure where though.

deadlandmine
08-26-2005, 06:30 PM
Thanks for taking a look. I don't think that's the problem, however. Kalsey's original CSS (which works in PC/IE) is:


#menu #subnav-1,
#menu #subnav-2,
#menu #subnav-3,
#menu #subnav-4 {
display : none;
width: 90%;
}

body.section-1 #menu ul#subnav-1,
body.section-2 #menu ul#subnav-2,
body.section-3 #menu ul#subnav-3,
body.section-4 #menu ul#subnav-4 {
display : inline;
left : 10px;
position : absolute;
top : 95px;
}
I have, in my attempts to find a solution, added the positioning to both the "turned off" information (#menu #subnav-1...) and the "turned on" information, but that doesn't make any difference in how it works in PC/IE (and I began with it just as Kalsey has it, and no dice).

By the way, I once noticed very strange behavior in PC/IE, where SOMETIMES (as I was clicking around through the different sections of the site) I would see the subnav menu, but most of the time I would not. I have NO IDEA what would cause that.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum