PDA

View Full Version : permissions---maybe you'll know



ajei
09-14-2002, 09:13 PM
ive placed all the cgi components on my server (well...the cgi files aren't in the cgi-bin, but in a subfolder outside the cgi-bin<<-what the instructions told me)
but ive set all permissions to 755 for the cgi files...but when i type in the address to them (to "run" them) i get a file save box coming up.....or if i type in "?command=refresh" after "*.cgi" i get the cgi script coming up "viewable" to me

would any body know the problem...or what i could try to fix it??
im trying to install cgibiz.com's "where" script.
oh...btw, what are proper permissions on a .INI file ?

MCookie
09-15-2002, 06:12 PM
Seeing the source of your script means you're not permitted to run CGIs outside your CGI-BIN...
Best thing to do is contact your host, I guess.

Inci
09-16-2002, 10:57 AM
Hello,

You have to use .htaccess file and write to it these two lines
Options +ExecCGI
AddHandler cgi-script pl cgi
then upload this file to the directory where your script reside

thats it..

MCookie
09-16-2002, 11:18 AM
Well Inci, if the server's main conf says "AllowOverride None" all .htaccesses are completely ignored. Better make a call first.

Inci
09-16-2002, 11:36 PM
Hello,

yup it's true.. i used many hosting providers in my life and many of them had AllowOverride set to Yes. So all my htaccess files worked perfectly.. but well call is a good decision too. But in lack of time htaccess file can save many hours or days.. so decision is yours. But anyways - i say only last thing - executing cgi script outside cgi-bin directory weakens server security in many ways. So you have to think twice before you will do it..

hope this helps..