...

View Full Version : Header problem...so frustrated!



BrookeAtVerite
06-20-2005, 01:35 AM
Here is the URL of my site: studioverite.sphosting.com
The problem, as you can see, is that the header doesn't fit right. I have tried EVERYTHING to fix this problem - editing the code and resizing the image over and over. Nothing seems to work! Help would be MUCH appreciated.

Here is the code of the site:

<html>
<head>
<title>Studio Verite</title>
<LINK href="cssm.css" rel="stylesheet" type="text/css">
</head>
<link rel="stylesheet" type="text/css" href="ai.css">
<body background="plusbg.jpg">

<table bgcolor="F9C26F" border="10" bordercolor="B22601" width="760" height="100%" align="center" valign="top" cellspacing="3" cellpadding="0">
<tr>
<td width="760" height="262" valign="middle" align="center" colspan="2" background="header.jpg">
</td>
</tr>

<tr>
<td width="125" height="100%" valign="top" bgcolor="E89B26">
<table width="100%"><tr><td><center><img src="explore.jpg" border="0"></center>
<a href="home.html" target="main"><font size=1><b>home</b></font></a><br>
<a href="expectations.html" target="main"><font size=1><b>expectations</b></font></a><br>
<a href="story.html" target="main"><font size=1><b>story</b></font></a><br>
<a href="family.html" target="main"><font size=1><b>the Verite family</b></font></a><br>
<a href="promote.html" target="main"><font size=1><b>promote</b></font></a><br>
<br>
<center> <img src=interact.jpg></center>
<a href="http://xsorbit28.com/users5/studioverite/index.php" target="main"><font size=1><b>forum (boards)</b></font></a><br>
<a href="mailto:studioverite@mail.com" target="new"><b><font size=1>email the owner</font></b></a><br>
<i><font size=1 color=#B22601 face=arial>(studioverite@mail.com)</font></i>
</td></tr></table>
</td>

<td width="630" height="100%" valign="top" bgcolor="#B04142">
<iframe src="home.html" name="main" width="629" height="625" border="0" frameborder="0"></iframe>
</td>
</tr>
</table>


</body>
</html>



Thank you!!

harbingerOTV
06-20-2005, 02:07 AM
is the banner sipposed to fit all the way across? Could it be that the header mage is only 750px while your table and td it's in is 760px wide?

and I also noticed that the 2 content td's add up to 755px. so after resizing the image and all that the bottom content section will still mess it up up top.

and you have 2 style sheets in your code. one is in the head and one is after the head. the one after the head will get ignored. and if you put them both in the head...only the later will load.

BrookeAtVerite
06-20-2005, 02:09 AM
I thought of that too, but the thing is, the image used to work. It only recently has stopped fitting, and I changed nothing. I've tried resizing the picture, but nothing changes.

BrookeAtVerite
06-20-2005, 02:12 AM
I see what you mean about not adding up to 760, so I made the TD with the width of 125px 130px instead, but it looks exactly the same.

harbingerOTV
06-20-2005, 02:21 AM
the iframe is too wide.

is pushing the td its in wider.



<html>
<head>
<title>Studio Verite</title>
</head>
<body background="http://studioverite.sphosting.com/plusbg.jpg">

<table bgcolor="F9C26F" border="10" bordercolor="B22601" width="760" height="100%"

align="center" valign="top" cellspacing="0" cellpadding="0">
<tr>
<td width="750" height="262" valign="middle" align="center" colspan="2"

background="http://studioverite.sphosting.com/header.jpg">
</td>
</tr>

<tr>
<td width="125" height="100%" valign="top" bgcolor="E89B26">
<table width="100%"><tr><td><center><img src="http://studioverite.sphosting.com/explore.jpg"

border="0"></center>
<a href="home.html" target="main"><font size=1><b>home</b></font></a><br>
<a href="expectations.html" target="main"><font size=1><b>expectations</b></font></a><br>
<a href="story.html" target="main"><font size=1><b>story</b></font></a><br>
<a href="family.html" target="main"><font size=1><b>the Verite family</b></font></a><br>
<a href="promote.html" target="main"><font size=1><b>promote</b></font></a><br>
<br>
<center> <img src="http://studioverite.sphosting.com/interact.jpg"></center>
<a href="http://xsorbit28.com/users5/studioverite/index.php" target="main"><font

size=1><b>forum (boards)</b></font></a><br>
<a href="mailto:studioverite@mail.com" target="new"><b><font size=1>email the

owner</font></b></a><br>
<i><font size=1 color=#B22601 face=arial>(studioverite@mail.com)</font></i>
</td></tr></table>
</td>

<td width="625px" height="100%" valign="top" bgcolor="#B04142">
<iframe src="http://studioverite.sphosting.com/home.html" name="main" width="620"

height="625" border="0" frameborder="0"></iframe>
</td>
</tr>
</table>


</body>
</html>

meth
06-20-2005, 02:22 AM
There's no single problem here, there are multiple problems. You have table and other element borders which are throwing out the required header cell width of 760px. Remember that border widths are added to the overall element width i.e. if you have a table width of 760px and apply a 10px border to it, the actual table width will be 780.

BrookeAtVerite
06-20-2005, 03:24 AM
Thanks everyone..finally fixed this!

harbingerOTV
06-20-2005, 03:36 AM
good deal

meth had the best way of going about it. forgot all about that border stuff for a second.

Like the look of the site overall. yellow as yellow is but pretty appealing for some reason. :thumbsup:



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum