...

View Full Version : Strange problem with frames and login script



Tester5
06-15-2005, 12:04 AM
One of my customers has a domain redirected with frame masking to a page in my server (so you always see www.domain.com instead of www.otherdomain.com/Username/index.htm)

The problem is that there is a page wich has restricted access using a simple php login script. Everything worked fine until, some days ago, I moved to a new server that seems to have a newer version of php. Now the login page works fine, as always, but it doesn't retain the session info anymore, so you always end again in the login page.

However, if I load the login page outside frames (i.e. I open www.otherdomain.com/Username/login.php) everything works ok... and if then, after logged in this way, I go to the framed page and navigate to the login page... it works!

Somebody knows how can I solve this problem?

nikkiH
06-15-2005, 02:01 PM
Is is possible that the new host is using URL re-writing for storing session info instead of cookies, when it was using cookies before?

Tester5
06-15-2005, 07:20 PM
Is is possible that the new host is using URL re-writing for storing session info instead of cookies, when it was using cookies before?

I don't think so... I seem to have find a solution, however, adding the session identifier variable (SID) in every link & form it works fine. I wonder if this can be done automatically

nikkiH
06-15-2005, 11:03 PM
That would be session URL re-writing.
Can be configured in the web server.

Session IDs are either stored as a cookie or passed via the URL. Looks like you're having a cookie domain issue, possibly due to the frames. Set the server to use URL re-writing or see if you can fix the domain issue.
Probably easier to set the server than to troubleshoot the cookies.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum