View Full Version : Widths Incorrect??

05-30-2005, 07:07 AM
I am apparently too close to this project.

The layout breaks in Opera (PC, 7.54) in that the right sidebar content doesn't display until below the left content is finished displaying. Take a look with Opera:

I'm thinking that it must be a problem with widths/margins/paddings (likely some combination of the three), but I can't find it. Search for:
/* Begin Structure */

That's where the trouble *should* be. Any help, as always, is much appreciated. Right now, I'm spending more time on the functionality of the site than the design, but there are people visiting the site so I'll need to solve this sidebar issue. Thanks, folks.

05-30-2005, 07:26 AM
Since its working fine on Opera 8, can you take a screen shot of what you see in 7.54?

05-30-2005, 09:45 AM
go with the latest version of opera why you are triggering in old versions of opera ?

05-30-2005, 12:27 PM
People use older versions of browsers so that they can see if they screw in them or not. Not everyone is using the latest IE6 SP2, Opera 8 or Firefox 1.0.4 etc, so you have to think about the user...how would they see it?

05-30-2005, 05:03 PM
The screengrab is attached (low quality, but you'll get the idea). The left sidebar content doesn't appear until after the main body content. I know I've dealt with this issue before on other projects, I just can't remember what the problem is and how to address it.

Anyone want to tell me how it's shaping up on a Mac? I'll check tomorrow at work and that may lead to a whole other set of problems, but since I'm here, I'd like to know if this sidebar problem is happening on a Mac, too. Thanks, all.

P.S. That's the version of Opera I use. I just don't care to upgrade it since I don't use it all that often and it works just fine. Some of your users are just like me, using old versions of Opera both because they are stubborn and because upgrading doesn't offer them anything that makes the download worth it.