...

View Full Version : Really odd problem...



Cmajor
05-19-2005, 04:54 PM
Hello,

First time on the forum so I'm sorry if I step on toes, I'll try and do better in the future!

My problem is I think, that my css file won't load. I've tried it on 1 mac and 2 PC's with the same result and it just seems to not be loading my style sheet. I've been frustrated with this since around noon yesterday with no luck fixing it. And to make things even weirder (Maybe) my normal style sheet works and loads just fine. If there is anyone out there that could help me I would greatly appreciate it!

Jason Pruim
Production & Technology Manager
Raoset Inc.
JApruim@nospam.raoset.com <-------Just remove "the nospam." part.

HTTP://www.raoset.com/index.shtml <----------- Web page
HTTP://www.raoset.com/media/redesign.css <----- CSS file

The menu at the top of the screen is supposed to be a deep red box with the links inside it. and the "statement of confidentiatlly" header is supposed to match the red. Any comments as far as how sucky my code is is appreciated as long as it's constructive. I really want to get better but I'm teaching myself and learning as I go.

SeeIT Solutions
05-19-2005, 05:08 PM
try putting the link to the css file under your meta tags.

Cmajor
05-19-2005, 05:27 PM
Same result. Could it be that the code doesn't validate 100%? There is a small section of the CSS that won't validate and I have no idea why? Although that shouldn't totally break the entire sheet just that particular element yes?

_Aerospace_Eng_
05-19-2005, 07:54 PM
The likely cause is the "comments" you are trying to use in your css file.

<!--Code for statement of confidentially
-->
is not a valid comment for CSS, a valid comment would appear like so,

/*Code for statement of confidentially*/

Cmajor
05-19-2005, 08:09 PM
Changed all the comments from HTML comments to CSS comments, still the same result...

So I ran it through the w3c's validator. and it spit this out and I can't find the errors my self, or at least how to fix them. Could this be causing the problem?

Line: 12 Context : p.state

Parse Error - ;) body { font-family: Helvetica, serif; color: black; background: white; margin-left: 5%; margin-right: 5%; }


Line: 26 Context : Code for text position

Parse Error - --> body div.text { display: none }


Line: 107 Context : Code for statement of confidentially

Parse Error - --> div.statement {text-align: center; margin-top: 2.5em; border-top: 5px solid black; border-bottom: 5px solid black; border-left: 5px solid black; border-right: 5px solid black; color: black; background: white; font-size: 85%; padding-top: 0em; padding-bottom: 0em; padding-left: 1em; padding-right: 1em; letter-spacing: 1px;}


Line: 128 Context : Code for header on top of screen

Parse Error - --> div.nav { display: none }

Cmajor
05-19-2005, 09:31 PM
Okay... So I think I narrowed it down to being a problem with the navigation div and the text div. When I copied individual parts of the style sheet into another sheet for testing it worked until I put those sections in. Weird huh? All the code in those 2 sections validate so it's all valid, can't find anything that says to me this is wrong, no flags....

_Aerospace_Eng_
05-20-2005, 12:22 AM
ha! its not valid


p.state {font-size: 85%; padding-left:1em; padding-right: 1em; padding-top: 0em; border-top: 3px solid black; border-bottom: 3px solid black; border-left: 3px solid black; border-right: 3px solid black;)
You closed off a style with a ) and not a }



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum